Bug 1025025 - [Tracking] openstack-cinder-volume service doesn't reconnect to qpidd after qpidd restart
[Tracking] openstack-cinder-volume service doesn't reconnect to qpidd after q...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
3.0
Unspecified Unspecified
medium Severity medium
: z2
: 4.0
Assigned To: Eric Harney
Dafna Ron
storage
: Reopened, TestOnly, ZStream
Depends On: 1050215 1054246
Blocks: 1065428
  Show dependency treegraph
 
Reported: 2013-10-30 14:46 EDT by Dan Yocum
Modified: 2018-02-08 05:07 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
This is a tracker bug with only one related fix for 4.0. Bug 1054246 will cover doc text requirements for that.
Story Points: ---
Clone Of:
: 1065428 1075684 (view as bug list)
Environment:
Last Closed: 2014-03-04 15:12:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
errors in volume.log file (14.54 KB, text/x-log)
2013-10-30 14:47 EDT, Dan Yocum
no flags Details
qpid errors in /var/log/messages (2.16 KB, text/plain)
2013-10-30 14:47 EDT, Dan Yocum
no flags Details
test log (10.29 KB, text/plain)
2013-11-13 15:30 EST, Eric Harney
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0213 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform 4 Bug Fix and Enhancement Advisory 2014-03-04 20:11:55 EST

  None (edit)
Description Dan Yocum 2013-10-30 14:46:18 EDT
Description of problem:

When the qpidd service is restarted, openstack-cinder-volume requires a restart to reconnect to the qpidd service.

Version-Release number of selected component (if applicable):


openstack-cinder-2013.1.3-2.el6ost.noarch


How reproducible:

Every

Steps to Reproduce:
1. Start qpidd and openstack-cinder-volume and verify cinder functionality (create/delete volumes, etc.)
2. Restart qpidd service
3. Again, try to create/delete cinder volumes.

Actual results:

Volumes fail to create/delete - displayed as in error state in dashboard

Expected results:

Volumes create/delete successfully.

Additional info:
Comment 1 Dan Yocum 2013-10-30 14:47:10 EDT
Created attachment 817591 [details]
errors in volume.log file
Comment 2 Dan Yocum 2013-10-30 14:47:56 EDT
Created attachment 817592 [details]
qpid errors in /var/log/messages
Comment 4 Eric Harney 2013-11-13 15:30:17 EST
Created attachment 823631 [details]
test log

Here is my attempt to reproduce this -- I couldn't.  No qpid errors generated in /var/log/messages and behavior is as expected.
Comment 5 Eric Harney 2013-11-13 15:31:26 EST
Dan: Any more info you can give about how to reproduce this?  It doesn't seem to happen on my machine.  (3.0.z on RHEL 6.5 Beta)
Comment 6 Dan Yocum 2013-11-20 12:57:11 EST
Sadly, no, I don't have any more details right now.  I'll try to reproduce the problem when I find some spare time (buwahahahaha!  I crack me up), but I don't see that happening any time soon.  :/

I'm ok with closing the ticket and if/when I run into it again, I'll re-open with more details.
Comment 7 Eric Harney 2013-11-27 09:37:01 EST
Closing since I can't find any way to make this happen.  Note that the errors in the volume log appear to be related to driver issues and not AMQP.
Comment 10 Dan Yocum 2014-01-08 08:48:03 EST
Let's leave this open for the next couple of weeks.

If/when the problem reproduces itself, we won't touch the volume service and you can log in and see what it's failing on.  Sound like a plan?
Comment 11 Gordon Sim 2014-01-08 11:22:21 EST
The qpidd errors sound like it might be https://bugzilla.redhat.com/show_bug.cgi?id=1041575 (see https://bugs.launchpad.net/cinder/+bug/1187298).
Comment 12 Eric Harney 2014-01-14 18:04:54 EST
Bug 1050215 could be related/helpful here.
Comment 14 Ayal Baron 2014-02-05 09:29:11 EST
Since this is a test only bug and the bug it's tracking is closed already as well as us not being able to reproduce it, I'm moving to ON_QA.
Comment 17 Dafna Ron 2014-02-19 05:05:09 EST
This specific issue is not reproduced but we have a different one which I will open a bug for. 
closing this as verified with the following packages 

[root@orange-vdsf ~]# rpm -qa |grep cinder
openstack-cinder-2013.2.2-1.el6ost.noarch
python-cinderclient-1.0.7-2.el6ost.noarch
python-cinder-2013.2.2-1.el6ost.noarch

root@puma31 ~]# rpm -qa |grep qpid
qpid-cpp-client-0.18-14.el6.x86_64
qpid-cpp-server-0.18-14.el6.x86_64
python-qpid-0.18-4.el6.noarch
Comment 21 errata-xmlrpc 2014-03-04 15:12:56 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0213.html

Note You need to log in before you can comment on or make changes to this bug.