Bug 1025098 - [abrt] dnf-0.4.6-1.fc20: repo.py:207:_handle_new_remote:AttributeError: 'module' object has no attribute 'LRO_FASTESTMIRRORCACHE'
[abrt] dnf-0.4.6-1.fc20: repo.py:207:_handle_new_remote:AttributeError: 'modu...
Status: CLOSED DUPLICATE of bug 1024776
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:3402776b9c8d3d66c208ed8fbfa...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 21:58 EDT by Ankur Sinha (FranciscoD)
Modified: 2013-10-31 02:34 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-31 02:34:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.50 KB, text/plain)
2013-10-30 21:59 EDT, Ankur Sinha (FranciscoD)
no flags Details
File: environ (2.19 KB, text/plain)
2013-10-30 21:59 EDT, Ankur Sinha (FranciscoD)
no flags Details
Traceback (1.07 KB, text/plain)
2013-10-30 22:47 EDT, lnie
no flags Details

  None (edit)
Description Ankur Sinha (FranciscoD) 2013-10-30 21:58:54 EDT
Description of problem:
Ran sudo dnf install sl and it crashed

Version-Release number of selected component:
dnf-0.4.6-1.fc20

Additional info:
reporter:       libreport-2.1.9
cmdline:        /usr/bin/python /bin/dnf install sl
executable:     /bin/dnf
kernel:         3.11.6-301.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
repo.py:207:_handle_new_remote:AttributeError: 'module' object has no attribute 'LRO_FASTESTMIRRORCACHE'

Traceback (most recent call last):
  File "/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 277, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 133, in _main
    result, resultmsgs = cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1360, in run
    load_available_repos=lar)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 223, in activate_sack
    self._add_repo_to_sack(r.id)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 133, in _add_repo_to_sack
    repo.load()
  File "/usr/lib/python2.7/site-packages/dnf/repo.py", line 411, in load
    if self._try_revive():
  File "/usr/lib/python2.7/site-packages/dnf/repo.py", line 287, in _try_revive
    handle = self._handle_new_remote(tmpdir)
  File "/usr/lib/python2.7/site-packages/dnf/repo.py", line 207, in _handle_new_remote
    h.setopt(librepo.LRO_FASTESTMIRRORCACHE,
AttributeError: 'module' object has no attribute 'LRO_FASTESTMIRRORCACHE'

Local variables in innermost frame:
h: <dnf.repo._Handle object at 0xd82950>
self: <Repo fedora>
mirrorlist: 'https://mirrors.fedoraproject.org/metalink?repo=fedora-20&arch=x86_64'
destdir: '/tmp/dnf-mx9X5C'
mirror_setup: True
Comment 1 Ankur Sinha (FranciscoD) 2013-10-30 21:59:04 EDT
Created attachment 817688 [details]
File: backtrace
Comment 2 Ankur Sinha (FranciscoD) 2013-10-30 21:59:08 EDT
Created attachment 817689 [details]
File: environ
Comment 3 lnie 2013-10-30 22:46:08 EDT
Also see this bug when run "dnf install xchat","dnf grouplist","dnf group list"
with the latest dnf.
Comment 4 lnie 2013-10-30 22:47:50 EDT
Created attachment 817696 [details]
Traceback
Comment 5 Ales Kozumplik 2013-10-31 02:34:47 EDT
Hello, this is a dupe of bug 1024776.

*** This bug has been marked as a duplicate of bug 1024776 ***

Note You need to log in before you can comment on or make changes to this bug.