Bug 1024776 - librepo version mismatch (no attribute 'LRO_FASTESTMIRRORCACHE')
librepo version mismatch (no attribute 'LRO_FASTESTMIRRORCACHE')
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
: Reopened
: 1025098 1025698 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 07:58 EDT by Jóhann B. Guðmundsson
Modified: 2013-11-16 02:11 EST (History)
12 users (show)

See Also:
Fixed In Version: dnf-0.4.7-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-16 02:11:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2013-10-30 07:58:41 EDT
Description of problem:

After updating to the latest release as the time of this writing dnf craps itself when running for example simple "dnf update" with

Traceback (most recent call last):
  File "/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 277, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 133, in _main
    result, resultmsgs = cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1360, in run
    load_available_repos=lar)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 223, in activate_sack
    self._add_repo_to_sack(r.id)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 133, in _add_repo_to_sack
    repo.load()
  File "/usr/lib/python2.7/site-packages/dnf/repo.py", line 420, in load
    handle = self._handle_new_remote(tmpdir)
  File "/usr/lib/python2.7/site-packages/dnf/repo.py", line 207, in _handle_new_remote
    h.setopt(librepo.LRO_FASTESTMIRRORCACHE,
AttributeError: 'module' object has no attribute 'LRO_FASTESTMIRRORCACHE'


Version-Release number of selected component (if applicable):
dnf-0.4.6-1.fc20.noarch.rpm hawkey-0.4.4-1.fc20.x86_64.rpm python-hawkey-0.4.4-1.fc20.x86_64.rpm libsolv-0.4.0-1.gitd49d319.fc20.x86_64.rpm

How reproducible:

Always

Steps to Reproduce:
1. dnf update
2.
3.

Actual results:

dirty python traceback

Expected results:

Pony and a Czech beer

Additional info:
Comment 1 Ales Kozumplik 2013-10-30 09:49:03 EDT
Hey there, what's your librepo version?
Comment 2 Ales Kozumplik 2013-10-30 09:53:45 EDT
The problem probably is we are not depending on the most recent librepo in that build---so even if it's available in the updates-testing just like DNF it doesn't get pulled if you select 'dnf' explicitly.

'yum upgrade python-librepo' should fix this. In master this is fixed by a8d4f2d and all should work as expected with dnf-0.4.7.
Comment 3 Ales Kozumplik 2013-10-30 09:55:20 EDT
CCing zpavlas: Zdenek, please make sure to bump the librepo version to the correct one (by communicating with tmlcoch perhaps) to prevent bugs like this in the future.
Comment 4 Ales Kozumplik 2013-10-31 02:34:11 EDT
OK it seems that the correct librepo version was omitted from updates, waiting for librepo maintainer to do a new build.
Comment 5 Ales Kozumplik 2013-10-31 02:34:47 EDT
*** Bug 1025098 has been marked as a duplicate of this bug. ***
Comment 6 Niki Guldbrand 2013-10-31 16:34:56 EDT
seeing this too.

dnf-0.4.6-1.fc20
hawkey-0.4.4-1.fc20
libsolv-0.4.0-1.gitd49d319.fc20
Comment 7 Ales Kozumplik 2013-11-01 03:30:08 EDT
(In reply to Niki Guldbrand from comment #6)
> seeing this too.
> 
> dnf-0.4.6-1.fc20
> hawkey-0.4.4-1.fc20
> libsolv-0.4.0-1.gitd49d319.fc20

Niki, what's your librepo version?
Comment 8 Niki Guldbrand 2013-11-01 04:12:00 EDT
sorry, gave the wrong info :-/

librepo-1.2.1-3.bc2c8a5.fc20
Comment 9 Kevin Raymond 2013-11-01 04:18:10 EDT
I got this issue testing last dnf build.
Which does not update my librepo package: still had
python-librepo-1.2.1-3.bc2c8a5.fc20.x86_64

Manually upgrading to python-librepo-1.3.0-1.fc20.x86_64
solved this. Might be a require directive to update?
Comment 10 Zdeněk Pavlas 2013-11-01 06:41:16 EDT
*** Bug 1025698 has been marked as a duplicate of this bug. ***
Comment 11 Niki Guldbrand 2013-11-02 06:18:41 EDT
librepo-1.3.0 fixed this issue on my end too
Comment 12 lnie 2013-11-05 01:14:51 EST
fixed with librepo-1.3.0
Comment 13 Fedora Update System 2013-11-11 08:44:10 EST
dnf-0.4.7-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.4.7-1.fc20
Comment 14 Fedora Update System 2013-11-11 19:40:41 EST
Package dnf-0.4.7-1.fc20, hawkey-0.4.5-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.4.7-1.fc20 hawkey-0.4.5-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21117/hawkey-0.4.5-1.fc20,dnf-0.4.7-1.fc20
then log in and leave karma (feedback).
Comment 15 Fedora Update System 2013-11-16 02:11:19 EST
dnf-0.4.7-1.fc20, hawkey-0.4.5-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.