Bug 102514 - exec-shield kills tuxracer
exec-shield kills tuxracer
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: tuxracer (Show other bugs)
1.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-08-16 06:06 EDT by Markku Kolkka
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-22 06:26:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
compressed strace output (51.49 KB, application/x-gzip)
2003-08-18 07:50 EDT, Markku Kolkka
no flags Details

  None (edit)
Description Markku Kolkka 2003-08-16 06:06:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
If tuxracer is run with exec-shield enabled, it crashes with segmentation fault
at startup. 

Version-Release number of selected component (if applicable):
tuxracer-0.61-23

How reproducible:
Always

Steps to Reproduce:
1.echo 3 > /proc/sys/kernel/exec-shield
2.tuxracer
3.
    

Actual Results:  Tuxracer opens a blank screen, plays one note of sound and
quits. The following is output on the terminal:
$ tuxracer
Tux Racer 0.61 -- a Sunspire Studios Production (http://www.sunspirestudios.com)
(c) 1999-2000 Jasmin F. Patry <jfpatry@sunspirestudios.com>
"Tux Racer" is a trademark of Jasmin F. Patry
Tux Racer comes with ABSOLUTELY NO WARRANTY. This is free software,
and you are welcome to redistribute it under certain conditions.
See http://www.gnu.org/copyleft/gpl.html for details.

mcop warning: user defined signal handler found for SIG_PIPE, overriding
mcop warning: user defined signal handler found for SIG_PIPE, overriding
Fatal signal: Segmentation Fault (SDL Parachute Deployed)
warning: leaving MCOP Dispatcher and still 143 types alive.


Expected Results:  Tuxracer runs (as it does with exec-shield disabled).

Additional info:

RHL 9.0.93 (Severn) + Rawhide 20030815
Comment 1 Ngo Than 2003-08-18 07:06:57 EDT
strange, it works for me with echo 3 > /proc/sys/kernel/exec-shield.

Which SDL/kernel/tuxracer version do you have?

could you please attatch the strace log "strace -o tuxracer.log tuxracer" ?
Comment 2 Markku Kolkka 2003-08-18 07:50:00 EDT
Created attachment 93707 [details]
compressed strace output

kernel 2.4.21-20.1.2024.2.1.nptl (i686)
SDL-1.2.5-9
tuxracer-0.61-23
Comment 3 Markku Kolkka 2003-10-22 06:26:38 EDT
Fixed in Fedora Core test3, tuxracer works with  
echo 2 > /proc/sys/kernel/exec-shield 

Note You need to log in before you can comment on or make changes to this bug.