Bug 1025208 - Impossible to build picketlink-sts quickstart example
Impossible to build picketlink-sts quickstart example
Status: CLOSED NOTABUG
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Quickstarts (Show other bugs)
6.2.0
Unspecified Unspecified
urgent Severity medium
: ---
: ---
Assigned To: sgilda
Vladimir Rastseluev
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 05:10 EDT by Vladimir Rastseluev
Modified: 2014-01-12 19:22 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-31 09:26:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
picketlink-sts mvn clean install log (96.44 KB, text/plain)
2013-10-31 08:37 EDT, sgilda
no flags Details
picketlink-sts configure and deploy log (6.18 KB, text/plain)
2013-10-31 09:00 EDT, sgilda
no flags Details
My Maven settings file (2.38 KB, text/xml)
2013-10-31 09:10 EDT, sgilda
no flags Details

  None (edit)
Description Vladimir Rastseluev 2013-10-31 05:10:44 EDT
Description of problem:
Build command in picketlink-sts quickstarts fail

Version-Release number of selected component (if applicable):
EAP 6.2 ER7

How reproducible:
easy

Steps to Reproduce:
1.cd $QUICKSTARTS_ROOT/picketlink-sts
2.mvn clean install


Actual results:
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 6.341s
[INFO] Finished at: Thu Oct 31 10:02:09 CET 2013
[INFO] Final Memory: 4M/66M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project jboss-picketlink-sts: Could not resolve dependencies for project org.jboss.quickstarts.eap:jboss-picketlink-sts:war:6.2.0.GA: Could not find artifact org.picketlink:picketlink-core:jar:2.1.9.Final-redhat-1 in jboss-public-repository-group (https://repository.jboss.org/nexus/content/groups/public-jboss) -> [Help 1]


Expected results:
build success

Additional info:
probably problem is related to this bug:
https://bugzilla.redhat.com/show_bug.cgi?id=1024352 jboss-eap-bom-parent 6.2.0-build-7 still has picketlink version 2.1.6.3.Final-redhat-2
Comment 1 John Doyle 2013-10-31 08:14:10 EDT
I consider this a blocker.
Comment 3 sgilda 2013-10-31 08:35:35 EDT
I am not able to reproduce this with ER7.

I downloaded the quickstarts and Maven repository from here: 

http://download.devel.redhat.com/devel/candidates/JBEAP/JBEAP-6.2.0-ER7/

I deleted my existing Maven repository.
I configured the settings using the example-settings.xml file located in the Maven zip, replacing the url 'file:///path/to/repo/jboss-eap-6.2.0.GA-maven-repository' with the path to the extracted ER7 Maven repository.

I run 'mvn clean install' and get BUILD SUCCESS.

I will attach the entire trace so you can compare.
Comment 4 sgilda 2013-10-31 08:37:03 EDT
Created attachment 817884 [details]
picketlink-sts mvn clean install log

The trace of my 'mvn clean install' for the picketlink-sts quickstart.
Comment 5 sgilda 2013-10-31 09:00:09 EDT
Created attachment 817892 [details]
picketlink-sts configure and deploy log

Results of configuring the server and deploying the application.
Comment 6 sgilda 2013-10-31 09:10:33 EDT
Created attachment 817904 [details]
My Maven settings file

I used the example-settings.xml file located in the root of the Maven zip and modified it to use the Maven download. So my settings.xml uses these repositories:

file:///home/sgilda/Downloads/jboss-eap-6.2.0.GA-maven-repository-ER7
http://repository.jboss.org/nexus/content/groups/public/
Comment 7 Vladimir Rastseluev 2013-10-31 09:25:15 EDT
I used old local repo for build so there was a conflict. Checked with no repo as @sgilda suggested. I confirm, that all builds fine. Sorry, my fault. Bug can be closed.

Note You need to log in before you can comment on or make changes to this bug.