Bug 1025306 - lxde spin will cannot format encrypted: interface bug
lxde spin will cannot format encrypted: interface bug
Status: CLOSED DUPLICATE of bug 921948
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 08:55 EDT by feddy
Modified: 2013-11-01 17:19 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-01 14:29:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description feddy 2013-10-31 08:55:12 EDT
Description of problem:
LXDE spin blocks cursor in password entry. Impossible to advance to p/w confirmation entry. Hence encypted installation impossible.


Version-Release number of selected component (if applicable):
as per Fed 19 LXDE spin live CD

How reproducible:
Everytime.

Steps to Reproduce:
1. Boot LXDE spin ; click 'install to disk' icon.
2. Select a partition to be assigned to / ; select reformat and check encypted; Done
2b. review intended reformating options , OK
3. Proceed: interface requests encryption phrase. Make long enought to attain "good" 
4. try to get cursor to 'confirm' input box.

Actual results:
Impossible to get text entry cursor to move from pass phrase entry box to confirmation entry box. 

Impossible to proceed with encrypted installation

Expected results:
Ability to pass to confimation box , comfirm and proceed with installation.


Additional info:
Comment 1 David Shea 2013-10-31 14:33:02 EDT
How are you trying to navigate to the input box, keyboard or mouse? Is this the only input you have trouble with, or do the other inputs on the custom partitioning screen behave similarly?
Comment 2 feddy 2013-10-31 17:41:01 EDT
keyboard or mouse? Both !

I would expect hitting enter to move to next input. No.
I would expect mouse click in confirmation box to move cursor, No. 

I would expect tab key to move to next input, but I sticks a "no entry" road sign at the end of the pass phrase input box and retains mouse focus.

It is thus _impossible_ to get out of this any other way than cancel. ie abandon input of pass-phrase and thus the possiblitily to set up an encrypted partition. 


The last point is in contrast to the main kde spin which does accept a tab key. 

This is still defective since tab is probably the least well known way to get to another input and there is not reason why other means of changing the focus should not work.
Comment 3 David Shea 2013-11-01 10:53:52 EDT
Both keyboard and mouse input work fine. The confirmation box is insensitive when the passphrase is weak, but that changes as soon as the strength changes to "Fair"
Comment 4 feddy 2013-11-01 13:51:50 EDT
I've checked this again this afternoon with fed19 LXDE spin. Two things in previous comment are inaccurate. 


Firstly:

"Both keyboard and mouse input work fine."

Wrong. There is not way to get to confirmation with mouse, that is the most obvious and primary function and does not work. If it "works for you", does not mean it works universally and is not a bug. 

That is a pretty weak reason for closing a bug, it simply implies insufficient testing. 



Second point: 

I did find that I was able to tab once I reached "good", fair does _not_ enable the second input box. If you find that it does, that is further inconsistency in the interface.

This is also a usabiltiy issue since my initial understanding when the no entry icon popped up was that it was interpretting the tab-key press as an attempt to enter a tab character into the pass phrase and indicating it was an invalid input character. 

"No entry" icon is probably not a good choice for indicating "no leave". 

A clear case of obscurity by icons. 

If weak or fair strength pass phrases are blockers, they should be shown in red , NOT green. 


Were you testing this on lxde spin ? Probalby not since I found mouse did work on installation from KDE spin.
Comment 5 feddy 2013-11-01 14:00:01 EDT
recommentations:

no entry icon is illogical as used. If it to be meaningful it should be on the 'confirm' box since that is the one I'm trying to entry and that is the action being blocked. Otherwise some other icon that makes sense needs to be used to indicate the pass phrase is not yet acceptable. (red cross?)

If weak and fair are blockers, make the bar red until we reach "good". 

If 'fair' is supposed to be allowed, more testing needed, it did not allow me to move on util I hit "good". 

Mouse is a problem on LXDE spin, confirm this then find out why it is different on KDE spin.
Comment 6 David Shea 2013-11-01 14:29:55 EDT

*** This bug has been marked as a duplicate of bug 921948 ***
Comment 7 feddy 2013-11-01 17:19:44 EDT
In view of info in dupe, adding this was on i686 version of LXDE spin. 

 bug 921948 reports x86-64

thx

Note You need to log in before you can comment on or make changes to this bug.