Bug 1025346 - kickstart sometimes hangs in summary hub
kickstart sometimes hangs in summary hub
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.0
All Linux
unspecified Severity high
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
: 1152860 (view as bug list)
Depends On:
Blocks: 1025347
  Show dependency treegraph
 
Reported: 2013-10-31 10:15 EDT by Brian Lane
Modified: 2014-12-12 15:43 EST (History)
3 users (show)

See Also:
Fixed In Version: anaconda-19.31.32-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1025347 (view as bug list)
Environment:
Last Closed: 2014-06-13 08:03:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Lane 2013-10-31 10:15:14 EDT
Description of problem:
Sometimes a kickstart installation with all required information will hang in the summary hub until the continue button is manually clicked.

How reproducible:
Variable. I was able to consistently reproduce with a minimal kickstart and livemedia-creator run, but the conditions likely depend on my local setup.

Steps to Reproduce:
1. Use rhel7-minimal.ks (not yet released)
2. Run livemedia-creator with ks
3. Use vnc to observe that it doesn't automatically continue.

The problem was due to a button click signal being blocked by a queue not being empty. The state of the queue likely depends on other variables like how fast it partitions the disk(s), how quickly the network status is updated, etc. so it may not always be reproducible.

In my local test setup I was able to get it to happen 100% of the time.
Comment 2 Jan Stodola 2014-01-22 06:33:51 EST
I've tried to create about 10 live images using livemedia-creator on 3 different machines and this issue didn't occur. Tested with anaconda-19.31.48-1.el7.

Moving to VERIFIED.
Comment 3 Ludek Smid 2014-06-13 08:03:15 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.
Comment 5 David Cantrell 2014-12-12 15:43:25 EST
*** Bug 1152860 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.