Bug 1025347 - kickstart sometimes hangs in summary hub
kickstart sometimes hangs in summary hub
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On: 1025346
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 10:16 EDT by Brian Lane
Modified: 2013-11-07 00:04 EST (History)
6 users (show)

See Also:
Fixed In Version: python-blivet-0.23.3-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1025346
Environment:
Last Closed: 2013-11-07 00:04:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Lane 2013-10-31 10:16:49 EDT
+++ This bug was initially created as a clone of Bug #1025346 +++

Description of problem:
Sometimes a kickstart installation with all required information will hang in the summary hub until the continue button is manually clicked.

How reproducible:
Variable. I was able to consistently reproduce with a minimal kickstart and livemedia-creator run, but the conditions likely depend on my local setup.

Steps to Reproduce:
1. Use rhel7-minimal.ks (not yet released)
2. Run livemedia-creator with ks
3. Use vnc to observe that it doesn't automatically continue.

The problem was due to a button click signal being blocked by a queue not being empty. The state of the queue likely depends on other variables like how fast it partitions the disk(s), how quickly the network status is updated, etc. so it may not always be reproducible.

In my local test setup I was able to get it to happen 100% of the time.
Comment 1 Fedora Blocker Bugs Application 2013-10-31 13:42:46 EDT
Proposed as a Freeze Exception for 20-beta by Fedora user bcl using the blocker tracking app because:

 kickstarts that sometimes work are annoying. especially when trying to create images with livemedia-creator
Comment 2 Fedora Update System 2013-11-04 23:06:44 EST
python-blivet-0.23.3-1.fc20, anaconda-20.25.6-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2013-20387/anaconda-20.25.6-1.fc20,python-blivet-0.23.3-1.fc20
Comment 3 Fedora Update System 2013-11-05 14:56:12 EST
Package python-blivet-0.23.3-1.fc20, anaconda-20.25.6-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-0.23.3-1.fc20 anaconda-20.25.6-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20387/anaconda-20.25.6-1.fc20,python-blivet-0.23.3-1.fc20
then log in and leave karma (feedback).
Comment 4 Mike Ruckman 2013-11-06 13:05:30 EST
Discussed in 2013-11-06 Blocker Review Meeting [1]. Skipped voting on this because it's already been pulled in. Marking that here for complete notes.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-11-06/
Comment 5 Fedora Update System 2013-11-07 00:04:46 EST
python-blivet-0.23.3-1.fc20, anaconda-20.25.6-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.