Bug 1025390 - RFE: save installation repository configuration in /etc/yum.repos.d
RFE: save installation repository configuration in /etc/yum.repos.d
Status: CLOSED DUPLICATE of bug 1119867
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
: FutureFeature, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 11:11 EDT by Karel Volný
Modified: 2014-10-30 13:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-30 13:19:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2013-10-31 11:11:37 EDT
Description of problem:
I've just did a network install from http://somethink...
After booting the system and trying to install some handy programs, yum complains that it has no repositories available.

Version-Release number of selected component (if applicable):
recent nightly

How reproducible:
always?

Steps to Reproduce:
1. do a network install - during installation, fill in your_local_RHEL_copy_URL
2. reboot
3. yum install mc

Actual results:
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
There are no enabled repos.
 Run "yum repolist all" to see the repos you have.
 You can enable repos with yum-config-manager --enable <repo>

Expected results:
(yum installs mc from the same source as the one used for system installation)

Additional info:
oh, and in addition, "yum-config-manager" is not installed ... really funny :-)
Comment 2 David Shea 2013-10-31 11:49:48 EDT
RHEL 6 has the same behavior: network repos are not added by default, use subscription-manager to register.
Comment 3 Karel Volný 2013-11-01 10:59:49 EDT
(In reply to David Shea from comment #2)
> RHEL 6 has the same behavior

well ... things can change, we have brand new installer rewrite, why not to include this?

was a change proposed/discussed/rejected?
(sorry for reopening if it was)

would that be possible to have the repository config saved under /etc/yum.repos.d/ having the repository disabled by default so that nothing changes at the first sight?
Comment 4 David Cantrell 2013-12-11 10:16:02 EST
Karel,

The request is valid, but software delivery for RHEL is much more complicated and involved in terms of company policy and such.  I want to keep this bug open and discuss possibilities during RHEL 7.1.
Comment 6 Brian Lane 2014-07-21 15:23:20 EDT
We have bug 1119867 which proposes adding a --install switch to the ks repo command. This limits it to addon repos and defaults to the current behavior so I think it's a good idea.
Comment 7 David Cantrell 2014-10-30 13:19:24 EDT

*** This bug has been marked as a duplicate of bug 1119867 ***

Note You need to log in before you can comment on or make changes to this bug.