Bug 1119867 - [RFE] add option to install custom repos on installed system
Summary: [RFE] add option to install custom repos on installed system
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Brian Lane
QA Contact: Release Test Team
URL:
Whiteboard:
: 1025390 (view as bug list)
Depends On:
Blocks: 1129913
TreeView+ depends on / blocked
 
Reported: 2014-07-15 17:13 UTC by Ross Smith
Modified: 2015-03-05 14:02 UTC (History)
3 users (show)

Fixed In Version: anaconda-19.31.83-1
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1129913 (view as bug list)
Environment:
Last Closed: 2015-03-05 14:02:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0312 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2015-03-05 17:35:22 UTC

Description Ross Smith 2014-07-15 17:13:26 UTC
Description of problem:
When one adds a repo to a kickstart install using the repo command, it is not added to the installed system.  It would be nice to specify which repos should be added to the instaled system.  

I think something like the following for the kickstart command would be useful.

repo --name myrepo --baseurl=https://example.com/myrepo --install


Version-Release number of selected component (if applicable):Rhel7GA


How reproducible:
always

Steps to Reproduce:
1. start a kickstart install using custom repos
2. finish install
3. yum repolist -> no custom repos

Actual results:
custom repos missing

Expected results:
custom repos installed on system.

Additional info:

Comment 3 David Cantrell 2014-10-30 17:19:24 UTC
*** Bug 1025390 has been marked as a duplicate of this bug. ***

Comment 4 Alexander Todorov 2014-11-24 14:42:22 UTC
See https://bugzilla.redhat.com/show_bug.cgi?id=1129913#c2 Moving to VERIFIED.

Comment 6 errata-xmlrpc 2015-03-05 14:02:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0312.html


Note You need to log in before you can comment on or make changes to this bug.