Bug 1025462 - iscsi storage domain: add possibility to check for backing lun extension
iscsi storage domain: add possibility to check for backing lun extension
Status: CLOSED DUPLICATE of bug 609689
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity low
: ---
: 3.4.0
Assigned To: Andrew Cathrow
Shai Revivo
storage
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 14:37 EDT by David Jaša
Modified: 2016-02-10 15:24 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-04 11:07:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2013-10-31 14:37:52 EDT
Description of problem:
some SANs allow online LUN extension. Using that in RHEV currently means some manual work:
1) on all hosts, rescan iscsi disks: echo "1" > /sys/block/sdX/device/rescan
2) on all hosts, resize multipathed device: multipathd -k'resize map dm-Y'
3) on SPM, run: pvresize /dev/dm-Y
4) let engine know current storage size (can be done by force-switching engine)

Version-Release number of selected component (if applicable):
encountered on 3.2

How reproducible:


Steps to Reproduce:
1. extend online backing iscsi LUN
2. try to make use of the new space in RHEV-M
3.

Actual results:


Expected results:


Additional info:
Comment 3 David Jaša 2013-11-04 11:07:36 EST
Yes. I didn't notice it while reporting so sorry for the noise.

*** This bug has been marked as a duplicate of bug 609689 ***

Note You need to log in before you can comment on or make changes to this bug.