Bug 609689 - [RFE] Need the ability to dynamically resize data domain luns
[RFE] Need the ability to dynamically resize data domain luns
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
2.1.0
All Linux
high Severity high
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Fred Rolland
Ori Gofen
http://www.ovirt.org/Features/LUN_Resize
: FutureFeature, Reopened, Triaged
: 745280 1025462 (view as bug list)
Depends On:
Blocks: 1302712
  Show dependency treegraph
 
Reported: 2010-06-30 16:34 EDT by Issue Tracker
Modified: 2016-07-21 23:52 EDT (History)
41 users (show)

See Also:
Fixed In Version: vdsm-4.17.0-1198.git6ede99a
Doc Type: Enhancement
Doc Text:
It is now possible to refresh LUN sizes in existing storage domains so that resized LUNs are properly represented in the Manager.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 15:24:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
frolland: needinfo-
sherold: Triaged+
ylavi: testing_beta_priority+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 17434 None None None Never
Red Hat Knowledge Base (Solution) 376873 None None None Never
oVirt gerrit 39528 master ABANDONED hsm: Add refreshPV verb Never
oVirt gerrit 43388 master MERGED resize-lun: Rescan fiber channel devices Never
oVirt gerrit 44588 ovirt-engine-3.6 MERGED webadmin: Rename column in add/edit SCSI/FC SD Never
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-09 20:20:52 EST

  None (edit)
Description Issue Tracker 2010-06-30 16:34:27 EDT
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2010-06-30 16:34:29 EDT
Event posted on 05-24-2010 11:18am EDT by rallton

Currently RHEV stores information about its storage in a metadata section of the disks.

Because of this it cannot properly handle the disks sizes or geometry changing since this does not get automatically updated.

Currently if a customer resizes the luns being presented to the OS then the RHEL system can handle this and steps can be taken to properly resize.
 
This event sent from IssueTracker by cww  [SEG - Feature Request]
 issue 930333
Comment 3 Yaniv Kaul 2011-10-14 12:41:34 EDT
*** Bug 745280 has been marked as a duplicate of this bug. ***
Comment 7 Ayal Baron 2013-01-16 06:15:25 EST
RHEV stopped storing this information in rhev 3.0 (domain format 2)
It is not straight forward though as you need to coordinate the extend on multiple hosts.  GSS has a kbase about how to do this (put all hosts except one in maintenance etc).
Comment 13 wdaniel 2013-09-06 10:28:07 EDT
My customer uses Nimble storage appliances in his environment, and from what I understand these devices use compression to add disk space. I'm not very familiar with these devices, but wanted to see if this RFE would support the kind of compression/resizing that Nimble uses. Any thoughts?
Comment 19 David Jaša 2013-11-04 11:07:36 EST
*** Bug 1025462 has been marked as a duplicate of this bug. ***
Comment 20 Evgheni Dereveanchin 2013-12-02 07:29:01 EST
Hi, any updates on whether this feature is planned to actually be implemented? If not - what's holding us? From my point of view the whole procedure is a mere "pvresize" combined with an LVM rescan on all hypervisors (not unlike the one already performed in case of new LUN addition).
Comment 21 David Jaša 2013-12-02 07:56:05 EST
(In reply to Evgheni Dereveanchin from comment #20)
> ...
> From my point of view the whole
> procedure is a mere "pvresize" combined with an LVM rescan on all
> hypervisors 

You need to rescan iscsi devices and resize multipathed device prior to pvresize invocation (as mentioned in the laste duplicate bug)
Comment 53 Waldirio M Pinheiro 2015-07-09 02:14:47 EDT
Do you believe be possible add a button in storage page (or another page) just to force in the hypervisor the rescan (iscsi, fc, etc) ?!

Customer asked me today about it and show me in vmware, a simple click in the button and enjoy, all lun's available in hypervisor. In RHEV, the easy way is restart the server (please let me know if are there another way to do it).

Thanks
Waldirio
Comment 54 Allon Mureinik 2015-07-09 02:30:01 EDT
(In reply to Waldirio M Pinheiro from comment #53)
> Do you believe be possible add a button in storage page (or another page)
> just to force in the hypervisor the rescan (iscsi, fc, etc) ?!
> 
> Customer asked me today about it and show me in vmware, a simple click in
> the button and enjoy, all lun's available in hypervisor. In RHEV, the easy
> way is restart the server (please let me know if are there another way to do
> it).
> 
> Thanks
> Waldirio
In the existing versions customers may be using (i.e., < 3.6) this is indeed a manual procedure, outlined in https://access.redhat.com/solutions/376873 .

RHEV 3.6.0 will provide this ability as a simple feature from the GUI. Additional details can be found in the upstream feature page, http://www.ovirt.org/Features/LUN_Resize .
Comment 58 errata-xmlrpc 2016-03-09 15:24:34 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html

Note You need to log in before you can comment on or make changes to this bug.