Bug 1025471 - CI tests are failing with "0-testvol-dht: (null): failed to get the 'linkto' xattr No data available" on clients.
CI tests are failing with "0-testvol-dht: (null): failed to get the 'linkto' ...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.1
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Bug Updates Notification Mailing List
Ben Turner
: Regression, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 14:59 EDT by Ben Turner
Modified: 2013-11-27 10:45 EST (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.38rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 10:45:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1769 normal SHIPPED_LIVE Red Hat Storage 2.1 enhancement and bug fix update #1 2013-11-27 15:17:39 EST

  None (edit)
Description Ben Turner 2013-10-31 14:59:07 EDT
Description of problem:

Our BVT and FS Sanity tests are currently failing on the latest 2.1 u1 build with:

[2013-10-31 14:52:53.727404] W [client-rpc-fops.c:1170:client3_3_fgetxattr_cbk] 0-testvol-client-11: remote operation failed: No data available
[2013-10-31 14:52:53.727807] W [client-rpc-fops.c:1170:client3_3_fgetxattr_cbk] 0-testvol-client-10: remote operation failed: No data available
[2013-10-31 14:52:53.727874] E [dht-helper.c:761:dht_migration_complete_check_task] 0-testvol-dht: (null): failed to get the 'linkto' xattr No data available
[2013-10-31 14:52:53.727914] W [page.c:991:__ioc_page_error] 0-testvol-io-cache: page error for page = 0x7f383805c4a0 & waitq = 0x7f38380ee500
[2013-10-31 14:52:53.727946] W [fuse-bridge.c:2617:fuse_readv_cbk] 0-glusterfs-fuse: 15163: READ => -1 (No such file or directory)

All the failed tests that I saw had similar logs on the clients.  On the server side I see:

[2013-10-31 15:35:49.675693] W [posix-helpers.c:788:posix_handle_pair] 0-testvol-posix: Extended attributes not supported (try remounting brick with 'user_xattr' flag)
[2013-10-31 15:35:49.675740] E [posix.c:915:posix_mknod] 0-testvol-posix: setting xattrs on /bricks/testvol_brick0/run6006/linux-2.6.31.1/.tmpconfig.7289 failed (Operation not supported)
[2013-10-31 15:35:57.423014] E [posix.c:915:posix_mknod] 0-testvol-posix: setting xattrs on /bricks/testvol_brick0/run6006/linux-2.6.31.1/.tmpconfig.h failed (Operation not supported)
[2013-10-31 15:36:00.109750] E [posix.c:915:posix_mknod] 0-testvol-posix: setting xattrs on /bricks/testvol_brick0/run6006/linux-2.6.31.1/include/linux/utsrelease.h.tmp failed (Operation not supported)

Has anything changed with how I need to mount bricks or is that warning a red herring?

Version-Release number of selected component (if applicable):

glusterfs-3.4.0.37rhs-1.el6_4.x86_64

How reproducible:

Every time I have ran automated tests on this build.

Steps to Reproduce:
1.  Compile the linux kernel on a glusterfs filesystem.
2.
3.

Actual results:

Compile fails.

Expected results:

Compile is successful.

Additional info:
Comment 3 Gowrishankar Rajaiyan 2013-11-01 02:25:49 EDT
For records:
<snip>
This is indeed a glusterfs regression. Bad patch is a quota related commit which has broken rename() and link() calls:

commit e411c02ced689255914dc2b602bede42c09bd787
Author: Raghavendra G <rgowdapp@redhat.com>
Date:   Wed Oct 30 14:15:23 2013 +0530

    cluster/dht: instruct marker whenever it shouldn't do accounting

    This is needed for two reasons:
    * since dht-linkfiles are internal, they shouldn't be accounted.
    * hardlink handling in marker is broken. link/unlink of hardlinks
      present in same directory can break marker accounting. Hence, if src
      and dst are in same directory in case of rename, dht - if it breaks
      rename into link/unlink operations - should instruct marker to not to
      do accounting.

    Change-Id: Id14127d526c472ebee7bec1cfcdcb79ed2e2be72
    BUG: 871015
    Signed-off-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-on: https://code.engineering.redhat.com/gerrit/14844
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Krishnan Parthasarathi <kparthas@redhat.com> 
</snip>
Comment 4 Amar Tumballi 2013-11-01 02:54:53 EDT
https://code.engineering.redhat.com/gerrit/14991
Comment 5 Ben Turner 2013-11-01 12:18:10 EDT
Verified on glusterfs-3.4.0.38rhs.  To note, I did see BZ 1025604 which still needs to be addressed, but the issues this BZ were opened for are resolved.
Comment 6 Raghavendra G 2013-11-06 01:54:21 EST
*** Bug 1026272 has been marked as a duplicate of this bug. ***
Comment 8 errata-xmlrpc 2013-11-27 10:45:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.