Bug 1026272 - quota:many files created with "---------T." permission
quota:many files created with "---------T." permission
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
high Severity urgent
: ---
: RHGS 2.1.2
Assigned To: Susant Kumar Palai
Saurabh
: Reopened, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 05:13 EST by Saurabh
Modified: 2016-01-19 01:13 EST (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.49rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:59:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-11-04 05:13:08 EST
Description of problem:

while creating data in a volume having quota enabled and limits set.
I am finding some files are created with no permissions except the sticky bit set for them

Version-Release number of selected component (if applicable):
glusterfs-3.4.0.38rhs-1

How reproducible:
many a times

Steps to Reproduce:
1. enable quota and set some limit on the volume.
2. mount over nfs or glusterfs, create a dir inside the mount-point
3. inside dir, create files of size 100MB till quota is reached.

Actual results:
---------T. 1 root root         0 Nov  4  2013 f.87
---------T. 1 root root         0 Nov  4  2013 f.88
---------T. 1 root root         0 Nov  4  2013 f.89
---------T. 1 root root         0 Nov  4  2013 f.9
---------T. 1 root root         0 Nov  4  2013 f.9
---------T. 1 root root         0 Nov  4  2013 f.90
---------T. 1 root root         0 Nov  4  2013 f.91
---------T. 1 root root         0 Nov  4  2013 f.92
---------T. 1 root root         0 Nov  4  2013 f.93
---------T. 1 root root         0 Nov  4  2013 f.94
---------T. 1 root root         0 Nov  4  2013 f.95
---------T. 1 root root         0 Nov  4  2013 f.96
---------T. 1 root root         0 Nov  4  2013 f.97
---------T. 1 root root         0 Nov  4  2013 f.98
---------T. 1 root root         0 Nov  4  2013 f.99

some of the file entries are seen twice, as in the case,
from glusterfs mount-point,
---------T. 1 root root         0 Nov  4  2013 f.47
---------T. 1 root root         0 Nov  4  2013 f.47

from nfs mount-point,
-rw-r--r--. 1 root root 104857600 Nov  4  2013 f.47
-rw-r--r--. 1 root root 104857600 Nov  4  2013 f.47



Expected results:
this is confusing. thought the quota limit are not crossed, creating files without permission and displaying different information from different moun-points is wrong.

Additional info:
Two entries for a single file was also seen in BZ 999399
Comment 3 Raghavendra G 2013-11-06 01:54:21 EST

*** This bug has been marked as a duplicate of bug 1025471 ***
Comment 4 Saurabh 2013-11-06 07:19:48 EST
why is this marked as CLOSED+DUPLICATE, I found this issue on glusterfs-3.4.0.38rhs-1 only
Comment 5 Saurabh 2013-11-06 07:28:27 EST
putting the question to rgowdapp@redhat.com for #c4, as needinfo automatically got assigned to rhs-bugs@redhat.com
Comment 6 Saurabh 2013-11-12 05:28:12 EST
I still can see the same behaviour for some files on latest build
i.e. glusterfs.3.4.0.43rhs-1


[root@rhsauto005 nfs-test-213]# ls -l
total 240
drwxr-xr-x. 2 root root   174 Nov 11 05:32 fstest_80bdef0589c380e61eba315ea420eca0
drwxr-xr-x. 2 root root   174 Nov 11 05:21 fstest_9fa807c6cde3e857e74fe740d6252541
drwxr-xr-x. 2 root root   174 Nov 11 05:33 fstest_b1b8c18cc7998312efca7c4969c43e7b
drwxr-xr-x. 2 root root   128 Nov 11 05:20 fstest_d4523850e89b6719425c7770db74e588
drwxrwxrwx. 2 root root    36 Nov 12 03:37 konsoul.test
---------T. 1 root root 65536 Nov 11 00:02 nfstest_posix_10591_20131111103021_f_61
---------T. 1 root root 65536 Nov 11 00:17 nfstest_posix_1099_20131111050818_f_61
---------T. 1 root root 65536 Nov 11 01:12 nfstest_posix_1171_20131111060212_f_61
drwxr-xr-x. 3 root root   126 Nov  6 13:34 run17446
drwxr-xr-x. 3 root root   126 Nov  4 16:51 run2278
drwxr-xr-x. 3 root root   150 Oct 31 03:43 run23329
drwxr-xr-x. 2 root root    54 Nov  4 02:58 run30546
drwxr-xr-x. 3 root root   126 Nov  8 08:43 run32523
drwxr-xr-x. 3 root root 49152 Nov 12 04:44 run-posix


[root@nfs1 ~]# glusterfs -V
glusterfs 3.4.0.43rhs built on Nov 11 2013 12:29:50
Comment 7 Saurabh 2013-11-12 05:33:03 EST
same from glusterfs mount,

[root@rhsauto005 ~]# cd /mnt/glusterfs-test
[root@rhsauto005 glusterfs-test]# ls -l
total 240
drwxr-xr-x. 2 root root   174 Nov 11 05:32 fstest_80bdef0589c380e61eba315ea420eca0
drwxr-xr-x. 2 root root   174 Nov 11 05:21 fstest_9fa807c6cde3e857e74fe740d6252541
drwxr-xr-x. 2 root root   174 Nov 11 05:33 fstest_b1b8c18cc7998312efca7c4969c43e7b
drwxr-xr-x. 2 root root   128 Nov 11 05:20 fstest_d4523850e89b6719425c7770db74e588
drwxrwxrwx. 2 root root    36 Nov 12 03:37 konsoul.test
---------T. 1 root root 65536 Nov 11 00:02 nfstest_posix_10591_20131111103021_f_61
---------T. 1 root root 65536 Nov 11 00:17 nfstest_posix_1099_20131111050818_f_61
---------T. 1 root root 65536 Nov 11 01:12 nfstest_posix_1171_20131111060212_f_61
drwxr-xr-x. 3 root root   126 Nov  6 13:34 run17446
drwxr-xr-x. 3 root root   126 Nov  4 16:51 run2278
drwxr-xr-x. 3 root root   150 Oct 31 03:43 run23329
drwxr-xr-x. 2 root root    54 Nov  4 02:58 run30546
drwxr-xr-x. 3 root root   126 Nov  8 08:43 run32523
drwxr-xr-x. 3 root root 49152 Nov 12 04:44 run-posix
Comment 9 Gowrishankar Rajaiyan 2013-12-12 04:35:48 EST
ON_QA to have this retested since dev is not able to reproduce it with U2 builds. Removing all needinfo flags as well.
Comment 12 errata-xmlrpc 2014-02-25 02:59:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.