Bug 102549 - Won't rip tracks because of recent change to cdparanoia
Won't rip tracks because of recent change to cdparanoia
Status: CLOSED DUPLICATE of bug 102051
Product: Red Hat Linux Beta
Classification: Retired
Component: grip (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-17 10:05 EDT by Jon Burgess
Modified: 2014-03-16 22:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Burgess 2003-08-17 10:05:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

Description of problem:
I noticed that grip doesn't rip any tracks with the new version of cdparanoia.
 



Version-Release number of selected component (if applicable):
grip-3.0.7-2

How reproducible:
Always

Steps to Reproduce:
1. Run grip
2. Insert audio CD
3. Select a track to rip
4. Select "Rip and Encode"

    

Actual Results:  Wait a few seconds, grip appears to be reading something but in
fact nothing is being read from the cd-rom


Expected Results:  CD-Rom should spin for a while as audio track being read,
file.wav should be created 

Additional info:

Doing an "strace -ff" on grip / cdparanoia show that it is failing because a
recent change has been made to cdparanoia to open /dev/scd0 with O_EXCL.

grip also has /dev/scd0 open when it calls cdparanoia, so cdparanoia retries a
few times to get an exclusive lock and then exits.

I downgraded to cdparanoia from RH9 and grip works OK.
Comment 1 Bill Nottingham 2003-08-17 21:09:35 EDT

*** This bug has been marked as a duplicate of 102051 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:07 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.