Bug 102051 - can't rip with grip/cdparanoia
Summary: can't rip with grip/cdparanoia
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: grip   
(Show other bugs)
Version: beta1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
: 101530 102549 (view as bug list)
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-08-09 19:35 UTC by Alexandre Oliva
Modified: 2014-03-17 02:38 UTC (History)
3 users (show)

Fixed In Version: 3.0.7-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-19 04:31:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexandre Oliva 2003-08-09 19:35:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
cdparanoia rightfully attempts to open the CD device with O_EXCL, but grip still
holds it open, so cdparanoia retries for a while and evetually gives up, without
ripping anything.  grip doesn't report any errors.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start grip
2.Try to Rip a CD

Actual Results:  The directory that should contain the ripped files is empty

Expected Results:  It should contain the .wav files (or, if encoding was
selected, the encode directory should contain the encoded files)

Additional info:

lsof -p in the CD-ROM device shows grip has the device open, while strace shows
cdparanoia is repeatedly attempting to open the same device with O_EXCL, and
reporting the failures to its stderr.

Comment 1 Miloslav Trmac 2003-08-10 13:39:36 UTC
This is a duplicate of bug 101530.

Comment 2 Alexandre Oliva 2003-08-10 19:34:54 UTC
*** Bug 101530 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2003-08-18 01:09:37 UTC
*** Bug 102549 has been marked as a duplicate of this bug. ***

Comment 4 Markku Kolkka 2003-08-18 13:16:32 UTC
Grip can be compiled with built-in cdparanoia, but it seems that this version is
compiled without that option because the entry for "grip (cdparanoia)" is
missing from the Config->Rip->Ripper selection list.

Comment 5 Bill Nottingham 2003-08-19 04:31:44 UTC
Both fixed in 3.0.7-3.

Comment 6 Alexandre Oliva 2003-08-20 06:44:49 UTC
Confirmed, thanks!


Note You need to log in before you can comment on or make changes to this bug.