Bug 1025511 - Cannot print PDFs to my HP LJ 1300
Cannot print PDFs to my HP LJ 1300
Status: CLOSED DUPLICATE of bug 1027332
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 16:36 EDT by Dale Snell
Modified: 2014-05-11 07:51 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-11 12:42:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The output from "lpinfo -l -v > printer-device-type.txt" (2.29 KB, text/plain)
2013-11-01 13:02 EDT, Dale Snell
no flags Details
The output from "grep -H '^*NickName:' /etc/cups/ppd/*.ppd > printer-driver.txt" (113 bytes, text/plain)
2013-11-01 13:04 EDT, Dale Snell
no flags Details
The output from "wget http://localhost:631/admin/log/error_log > cups-error-log.txt" (859.81 KB, text/plain)
2013-11-01 13:06 EDT, Dale Snell
no flags Details
The troubleshooting output from system-config-printer (30.81 KB, text/plain)
2013-11-01 13:09 EDT, Dale Snell
no flags Details

  None (edit)
Description Dale Snell 2013-10-31 16:36:44 EDT
Description of problem:

I can no longer print PDFs from most GUI PDF viewers to my HP LJ1300.  It has worked fine in previous versions of Fedora, and in F19 as originally installed.  After one or two updates of F19, printing failed.  No matter how many pages are selected to print, from one to an entire file, the printer issues one blank page, and one with some odd error message. The message looks to me more like PostScript than anything else.  It only takes up about a 2in x 2in square in the top left corner, though, so it's hard to tell what it really is.

I have tried evince, qpdfview, GSView. GNU GV fails, but it looks like it's trying to print a PS file, so I'm not surprised it doesn't work.  Oddly, the Xpdf program will print correctly, but it claims to be using the lpr command.  I tried the lpr command from the shell, and it mis-behaves like the other GUI viewers.


Version-Release number of selected component (if applicable):

1:1.6.4-2.fc19


How reproducible:

100%


Steps to Reproduce:
1. Open a PDF with evince, qpdfview, or some other GUI PDF viewer.
2. Attempt to print all or part of the document.
3. Error.


Actual results:

Two pages -- one blank, the other with a small amount of gibberish.


Expected results:

The selected PDF is printed correctly.


Additional info:

Cups was throwing an SELinux avc when I tried to print.  I fixed that (and sent in a bug report, a dup of 1023937), but it didn't help.
Comment 1 Jiri Popelka 2013-11-01 05:11:15 EDT
Does printing of other file types work ?
For example 'echo test | lpr' ?

Can you print something via printing troubleshooter [1] and attach an output here ? You can either print some pdf file like 'lpr file.pdf' or printing a test page should also be fine as test pages are submitted in pdf format.

[1] https://fedoraproject.org/wiki/How_to_debug_printing_problems#Printing_troubleshooter
Comment 2 Dale Snell 2013-11-01 13:02:20 EDT
Created attachment 818367 [details]
The output from "lpinfo -l -v > printer-device-type.txt"
Comment 3 Dale Snell 2013-11-01 13:04:22 EDT
Created attachment 818368 [details]
The output from "grep -H '^*NickName:' /etc/cups/ppd/*.ppd > printer-driver.txt"
Comment 4 Dale Snell 2013-11-01 13:06:41 EDT
Created attachment 818369 [details]
The output from "wget http://localhost:631/admin/log/error_log > cups-error-log.txt"
Comment 5 Dale Snell 2013-11-01 13:09:27 EDT
Created attachment 818370 [details]
The troubleshooting output from system-config-printer
Comment 6 Dale Snell 2013-11-01 13:15:36 EDT
I tried using system-config-printer, but it appeared to hang.  So I set up full debugging as suggested in the Printing Troubleshooter web page.  I checked for the device ID (printer-device-type.txt) and the printer driver (printer-driver.txt).  I then tried to print a groff source file using the lp command.  The source (.mom) version printed fine.  The PDF gave me the usual two wrong pages.  The PostScript version did not print.  The printer's activity light never even blinked.  That done, I copied the error log to a file (cups-error-log.txt).

Just 'cause, I tried system-config-printer again, and this time it started.  I followed the "troubleshoot" procedure, and everything seemed to go well, until I tried to print a test page.  At that point it gave me another(!) SELinux avc and sat there.  I was able to save a troubleshooting log (troubleshoot.txt).  That done, I tried to proceed, but it seemed to hang.  A minute or so later, though, it popped up an error window:

Error submitting test page
There was an error during the CUPS operation: 'Request Entity Too Large'.

BTW, here's the message on the printed page after trying to print a PDF:

ERROR:
invalidaccess
OFFENDING COMMAND:
filter
STACK:
endstream
0
--nostringval--
--nostringval--
24
false

Maybe it will help?  Anyway, I've attached the rest of the files to this comment.
Comment 7 Tim Waugh 2013-11-04 06:23:17 EST
The first thing to try is to change the driver to "hpcups":

1. First, install the hpijs package.
2. Now change the driver with this command, as root (paste it all in):

lpadmin -p Hewlett-Packard-hp-LaserJet-1300 \
        -m drv:///hp/hpcups.drv/hp-laserjet_1300-pcl3.ppd

Try printing now -- does it now work?
Comment 8 Dale Snell 2013-11-04 11:11:31 EST
Yippee!  It works!  I've tried printing single pages and entire documents, and it all worked as expected.

Thank you very much, Tim.  If you need me to check anything else, let me know.   I'll be happy to do so.
Comment 9 Joachim Frieben 2013-11-24 05:08:29 EST
Same problem here for an HP LaserJet 4000 and the default Postscript driver on current Fedora 20. Installed packages include:

- cups-1.7.0-4.fc20
- hpijs-3.13.11-2.fc20
- hplip-3.13.11-2.fc20
- system-config-printer-1.4.3-2.fc20

I am doubt that the hpcups driver has all the possibilities of the Postscript driver, thus the issue has only been identified but not solved.
Comment 10 Tim Waugh 2013-11-25 08:20:44 EST
Looks quite similar to bug #1027332.
Comment 11 Tim Waugh 2014-03-11 12:42:09 EDT

*** This bug has been marked as a duplicate of bug 1027332 ***
Comment 12 Ray Holme 2014-05-11 07:51:56 EDT
 and then installed a tool to config the 2100 and that fixed the final problem - all was printing grayscale. (g2100config).

Problem remaining is that ALL libre office printouts need to be set to normal as they default to ecosave mode (grayscale -save ink).

Note You need to log in before you can comment on or make changes to this bug.