This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1027332 - Printer doesn't work using LibreOffice/Poppler
Printer doesn't work using LibreOffice/Poppler
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: cups-filters (Show other bugs)
19
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
: 1025511 1027340 1067681 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-06 10:15 EST by happymaze
Modified: 2015-02-18 06:39 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-18 06:39:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
d* file from /var/spool/cups/ (657.95 KB, application/pdf)
2013-12-03 17:08 EST, Antonio A. Olivares
no flags Details
Comment (105.60 KB, text/plain)
2013-12-03 07:53 EST, Antonio A. Olivares
no flags Details

  None (edit)
Description happymaze 2013-11-06 10:15:46 EST
After I 'sudo yum update' the LibreOffice & system-config-printer about few days ago, my printer couldn't work properly after sending printing requests from LibreOffice/Poppler.

gedit works alright.

Printer Model No.
-----
hp LasterJet 1300


-----
system-config-printer.i686 0:1.4.3-2.fc19                                     
system-config-printer-libs.noarch 0:1.4.3-2.fc19                              
system-config-printer-udev.i686 0:1.4.3-2.fc19
libreoffice-core-4.1.3.2-2.fc19.i686
libreoffice-4.1.3.2-2.fc19.i686



Actual results:
-----
 ERROR:
 invalidaccess
 OFFENDING COMMAND
 filter
 STACK:
 /SubFileDecode
 endstream
 0
 --nostringval--
 --nostringval--
 693
 false

Expected results:
-----
 "The printed document"


Kernel version
-----
Linux 3.11.6-200.fc19.i686.PAE

Thanks!
Comment 1 Tim Waugh 2013-11-06 11:14:16 EST
*** Bug 1027340 has been marked as a duplicate of this bug. ***
Comment 2 Tim Waugh 2013-11-18 07:47:03 EST
Please attach the PPD for this queue from the /etc/cups/ppd/ directory.
Comment 3 Antonio A. Olivares 2013-12-03 07:53:28 EST
Created attachment 915814 [details]
Comment

(This comment was longer than 65,535 characters and has been moved to an attachment by Red Hat Bugzilla).
Comment 4 Tim Waugh 2013-12-03 08:14:50 EST
Thank you Antonio, but in future please use the "Add an attachment" link at the top of the bug report to add files. :-)

So, you said you get this print output when printing from Firefox:

ERROR:
timeout
OFFENDING COMMAND:
timeout
STACK:
-mark-
-mark-
-mark-

But in your original message:
https://lists.fedoraproject.org/pipermail/test/2013-December/119106.html

you described a different error message:
ERROR:
invalidaccess
OFFENDING COMMAND:
filter
STACK:
/SubFileDecode
endstream
0
--nostringval--
--nostringval--
9
false

You said you got this when you "print out a website" -- from that I'm assuming you were also printing from Firefox. So you are getting different errors when you print?

Is it always the same error when you print the same page?

I think we need to see the data that CUPS was given by Firefox or, in the original report, Libreoffice.

Here is how to do that:

1. 'cupsctl PreserveJobFiles=Yes' as root
2. Now submit the print job as before. Observe which error message is printed out.
3. 'cupsctl PreserveJobFiles=No' as root so you don't end up using up all your disk space keeping print job data
4. Now, as root, 'ls /var/spool/cups/d*' should show you the file to attach. Please attach that file to this bug report.
(You may have to copy it to your home directory first, and make it readable)
5. Very important: as well as attaching that file, please also include the error message from the print out.
Comment 5 Antonio A. Olivares 2013-12-03 12:48:05 EST
I cannot attach anything here in bugzilla.  Files are bigger than 2000K :(

[root@localhost cups]# cat c00018 
Gattributes-charsetutf-8Hattributes-natural-languageen-usBjob-originating-user-namolivaresE
                    printer-uri-ipp://localhost:631/printers/HP-LaserJet-1200job-namekInfowars » The Kardashian 2013 Christmas Card: A Tribute to the Illuminati Entertainment Industry » PrintB
job-sheetsnoneBnone"
                      HPEconoMode!	number-upPageSizeLetter"
ManualFeedB
Resolution1200dpiB	InputSlotAuto"HPStraightPaperPath!
                                                             job-priority"B
HPHalftonePrinterDefaultB	SmoothingPrinterDefaultIdocument-formatapplication/pdfjob-uuid-urn:uuid:9232a121-5a9e-33c9-4feb-591c012df664Bjob-originating-host-name	localhost!time-at-creationR��time-at-processingtime-at-completed!job-id#	job-stateDjob-state-reasonsnone!job-media-sheets-completedEjob-printer-uri5ipp://localhost.localdomain/printers/HP-LaserJet-1200!
                                                                       job-k-octetsTDjob-hold-untilno-hold[root@localhost cups]# 

[root@localhost cups]# ls -l
total 692
-rw-------. 1 root lp    952 Dec  3 11:44 c00018
-rw-------. 1 root lp    952 Dec  3 11:45 c00019
-rw-r-----. 1 root lp 347344 Dec  3 11:44 d00018-001
-rw-r-----. 1 root lp 347344 Dec  3 11:44 d00019-001
drwxrwx--T. 2 root lp   4096 Dec  3 11:44 tmp
[root@localhost cups]#
Comment 6 Antonio A. Olivares 2013-12-03 16:52:05 EST
Dear all,

I have gone into settings and the printer was turned off, turned it on.  It printed a page with:

ERROR:
syntaxerror
OFFENDING COMMAND:

STACK:
--nostringval--
true
--nostringval--
/ESPrs
--nostringval--

I cancelled the print jobs.  Then printed a test page.  It did not print.  The one page I tried printing yesterday[test page] printed today :(  I stopped the printer[turned it off] and back on.
Comment 7 Antonio A. Olivares 2013-12-03 17:08:09 EST
Created attachment 832311 [details]
d* file from /var/spool/cups/
Comment 8 Antonio A. Olivares 2013-12-03 17:10:00 EST
Hope this helps things clear up!  and sorry for not being able to attach file(s) first time  :(
Comment 9 Tim Waugh 2013-12-04 06:27:23 EST
Thanks. What does 'rpm -q cups cups-filters' say?

I'd also like you to try the following test:

1. cancel HP-LaserJet-1200 (this clears out the queue)
2. Print something that gives an error, and note the error
3. cancel HP-LaserJet-1200 (to clear out the queue again, just in case)
4. Print the very same thing again.

Do you get the very same error in steps 2 and 4, or do you get different results?
Comment 10 Antonio A. Olivares 2013-12-04 07:51:39 EST
Dear Sir,

[olivares@localhost ~]$ rpm -q cups cups-filters
cups-1.7.0-6.fc20.x86_64
cups-filters-1.0.41-4.fc20.x86_64
[olivares@localhost ~]$ 
I printed an article from wnd website:

http://www.wnd.com/2013/12/nobamacare-university-now-raises-stakes/print/

I get two pages one blank and one with :

ERROR:
invalidaccess
OFFENDING COMMAND:
filter
STACK:
/SubFileDecode
endstream
0
--nostringval--
--nostringval--
106
false

I check the printers queue it is empty.  So I can't apply step 3, but will proceed to step 4:

I apply step 4, and the printer's light is blinking but no printing occurs :(
The queue at the bottom tells me that printing is occurring or has occurred but nothing has come out.  

Thanks!
Comment 11 Jiri Popelka 2013-12-09 08:01:15 EST
This could be related with cups-filters using another pdftops renderer since 1.0.40. Previously we were using Poppler based renderer (called also pdftops) and since 1.0.40 we've used a renderer called 'hybrid' which uses Ghostscript in most cases and Poppler only in some cases.

This can be changed [1] at runtime with:
lpadmin -p <printer> -o pdftops-renderer-default=pdftops
and reset back with:
lpadmin -p <printer> -R pdftops-renderer-default

Could somebody give it a try and let me know if setting it to pdftops makes and change ?

[1] /usr/share/doc/cups-filters/README
Comment 12 Antonio A. Olivares 2013-12-09 10:00:49 EST
I ran 
[root@localhost ~]# lpadmin -p HP-Lasterjet-1200 -o pdftops-renderer-default=pdftops

and I try to print page referenced above and it(printer) prints two pages one empty and one with:

ERROR:
invalidacess
OFFENDING COMMAND:
filter
STACK:
/SubFileDecode
endstream
0
--nostringval--
--nostringval--
108
false

I check in systems settings and two printers show up with the same name but one is grayed out.  I will use other command to set it back and see what it does and post here:

It reports that it finished printing but no pages show up :(
and a run of dmesg shows:

[   39.543535] usblp0: removed
[   39.561515] usblp 3-3:1.0: usblp0: USB Bidirectional printer dev 2 if 0 alt 1 proto 2 vid 0x03F0 pid 0x0317


[  285.176571] usblp0: removed
[  295.709721] usblp 3-3:1.0: usblp0: USB Bidirectional printer dev 2 if 0 alt 1 proto 2 vid 0x03F0 pid 0x0317
[  529.581127] usblp0: removed
[  530.849483] usblp 3-3:1.0: usblp0: USB Bidirectional printer dev 2 if 0 alt 1 proto 2 vid 0x03F0 pid 0x0317
[root@localhost ~]#
Comment 13 Jiri Popelka 2013-12-09 10:19:30 EST
(In reply to Antonio A. Olivares from comment #12)
> It reports that it finished printing but no pages show up :(
> [   39.543535] usblp0: removed
> [   39.561515] usblp 3-3:1.0: usblp0: USB Bidirectional printer dev 2 if 0
> alt 1 proto 2 vid 0x03F0 pid 0x0317

Could you try also instructions in bug #873123, comment #0 (it'd be better to reply there, thanks).
Comment 14 Antonio A. Olivares 2014-02-11 13:02:27 EST
@ All 

In my case, being dissatisfied with the tools and the sudden change here.  I went back and removed(deleted) the printer from the (all settings ---> printer) and used the old tried and true (system-config-printer) added the printer and selected the recommended driver and unplugged and replugged the printer and it prints like the good old days.  I don't know about OP(original poster), but for me I have just gotten the printer to work like it used to for muliple versions of Fedora on this machine.  Thanks to all for your suggestions.  I actually got a friend(Phillipe Vouters from France) to help me.  And using his suggestions, I got it to work.  He wrote on a problem that he was having(using parallel port), and how he fixed it^{1} and how he set up an old printer to print from windows 7^{2}

1/ http://vouters.dyndns.org/tima/Linux_Fedora-CUPS-Cups_daemon_does_not_start_after_reboots.html
2/ http://vouters.dyndns.org/tima/Linux-CUPS-Fedora_upgrade_to_19_and_remote_printing.html

Best Regards,


Antonio

If you need further information, configuration file, just let me know and I'll send it.  I tested printing from Libreoffice and it worked and got no errors like I used to :)
Comment 15 Tim Waugh 2014-02-24 10:19:28 EST
*** Bug 1067681 has been marked as a duplicate of this bug. ***
Comment 16 JM 2014-03-11 12:19:18 EDT
I still have this problem and

lpadmin -p <printer> -o pdftops-renderer-default=pdftops

solved the problem for me. It looks like this is a 'bug' in Cups, at least I found other bug reports which an almost identical description, for example:

https://bugs.launchpad.net/ubuntu/+source/cups-filters/+bug/998087
Comment 17 Tim Waugh 2014-03-11 12:42:09 EDT
*** Bug 1025511 has been marked as a duplicate of this bug. ***
Comment 18 Joachim Frieben 2014-05-04 05:40:14 EDT
Issue persists for a fully updated Fedora 20 system using the PostScript driver with an HP LaserJet 4000 (just as reported in https://bugzilla.redhat.com/show_bug.cgi?id=1025511#c9) when printing some PDF file from within evince. Installed packages now include:

- cups-1.7.2-1.fc20
- cups-filters-1.0.41-6.fc20
- foomatic-4.0.9-6.fc20
- hplip-3.13.11-4.fc20
- system-config-printer-1.4.4-1.fc20
Comment 19 Fedora End Of Life 2015-01-09 17:21:36 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 20 Fedora End Of Life 2015-02-18 06:39:21 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.