Bug 102555 - Migrating ethernet config keeps old HWADDR
Summary: Migrating ethernet config keeps old HWADDR
Status: CLOSED DUPLICATE of bug 101488
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: kudzu   
(Show other bugs)
Version: beta1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-17 20:23 UTC by Leonard den Ottolander
Modified: 2014-03-17 02:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:58:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Leonard den Ottolander 2003-08-17 20:23:14 UTC
Description of problem:

(Running kudzu after exchanging a NIC at first kept the configuration for the
old card although I asked to delete it. Consequently the question to migrate the
old config to the new card wasn't asked. I was unable to reproduce this hickup.
Maybe more on this later.)

After restoring /etc/sysconfig/hwconf, /etc/modules.conf and
/etc/sysconfig/network-scripts/ifcfg-eth0 I reran kudzu. This time it
succesfully deleted the old NIC and asked whether to migrate the old config to
the new card. This resulted in the old config being maintained. Problem is that
also the HWADDR in the config is kept which results in the interface not being
brought down when the network is stopped:

Shutting down interface eth0:  Device eth0 has different MAC address than
expected, ignoring.


Version-Release number of selected component (if applicable):
kudzu-1.1.13-1.1


Expected results:

When migrating a NIC config the hardware address (HWADDR) should be updated in
/etc/sysconfig/network-scripts/ifcfg-ethx.

Comment 1 Bill Nottingham 2003-08-18 01:09:48 UTC

*** This bug has been marked as a duplicate of 101488 ***

Comment 2 Leonard den Ottolander 2003-08-18 12:29:13 UTC
Right. I did query Severn for kudzu bugs but I didn't query Taroon. Something to
rememember.
And ah, I see kudzu was updated on friday in RawHide. Also missed that. Just got
all the updates thursday ;) .


Comment 3 Red Hat Bugzilla 2006-02-21 18:58:07 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.