Bug 102563 - system hangs when PCMCIA cards are inserted, or with acpi=off
system hangs when PCMCIA cards are inserted, or with acpi=off
Status: CLOSED WONTFIX
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
beta1
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-08-17 23:10 EDT by Chris Ricker
Modified: 2015-01-04 17:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-26 23:36:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
verbose lspci (6.05 KB, text/plain)
2003-08-17 23:11 EDT, Chris Ricker
no flags Details
acpidmp from the HP 4400 Pavilion (115.79 KB, text/plain)
2003-08-26 09:59 EDT, Chris Ricker
no flags Details

  None (edit)
Description Chris Ricker 2003-08-17 23:10:15 EDT
This HP Pavilion 4400 series laptop has the following chipsets:

00:00.0 Host bridge: ATI Technologies Inc: Unknown device cab0 (rev 13)
00:01.0 PCI bridge: ATI Technologies Inc PCI Bridge [IGP 320M] (rev 01)
00:02.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:06.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link
Controller Audio Device (rev 02)
00:07.0 ISA bridge: ALi Corporation M1533 PCI to ISA Bridge [Aladdin IV]
00:08.0 Modem: ALi Corporation Intel 537 [M5457 AC-Link Modem]
00:0a.0 CardBus bridge: O2 Micro, Inc. OZ6912 Cardbus Controller
00:10.0 IDE interface: ALi Corporation M5229 IDE (rev c4)
00:11.0 Bridge: ALi Corporation M7101 PMU
00:12.0 Ethernet controller: National Semiconductor Corporation DP83815
(MacPhyter) Ethernet Controller
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility U1

The system boots and works if I boot kernel-2.4.21-20.1.2024.2.1.nptl.athlon and
don't use any PCMCIA / CardBus adapters. As soon as I insert a CardBus card (so
far, I've tried an Intel e100 10/100 NIC and a Linksys orinoco_cs wireless NIC
-- both work with severn in other laptops), the machine locks up completely.

If I boot the machine with acpi=off and have no CardBus cards inserted, it hangs
when the pcmcia init script runs
Comment 1 Chris Ricker 2003-08-17 23:11:46 EDT
Created attachment 93699 [details]
verbose lspci

In case it helps, here's the lspci -v output as well.
Comment 2 Jim Cornette 2003-08-19 23:21:21 EDT
With conversations on the rhl-beta list. I tried out my PCMCIA card for my
TravelScan portable PCMCIA scanner. I believe that the card was recognozed. I
got two beeps. I also got this in my /proc/bus/pccard/drivers file (Serial driver)

[jim@jcsevern pccard]$ cat /proc/bus/pccard/drivers
serial_cs                0 0

My laptop seems to use similar drivers for most cases. My problem is the device
is not recognized in the scanner program.

If you haven't done so yet, Check for a newer BIOS for your laptop.

my kernel version is below:

kernel-2.4.21-20.1.2024.2.1.nptl

I have a OZ6912 Cardbus controller listed under my PCMCIA and PC card entries,
under the harware browser.

This uses the yenta_socket driver.


good luck!

Jim C.
Comment 3 Jim Cornette 2003-08-19 23:23:52 EDT
here is my /sbin/lspci output.

00:00.0 Host bridge: ATI Technologies Inc: Unknown device cab0 (rev 13)
00:01.0 PCI bridge: ATI Technologies Inc PCI Bridge [IGP 320M] (rev 01)
00:02.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:06.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link
Controller Audio Device (rev 02)
00:07.0 ISA bridge: ALi Corporation M1533 PCI to ISA Bridge [Aladdin IV]
00:08.0 Modem: ALi Corporation Intel 537 [M5457 AC-Link Modem]
00:0a.0 CardBus bridge: O2 Micro, Inc. OZ6912 Cardbus Controller
00:0c.0 FireWire (IEEE 1394): Texas Instruments TSB43AB21 IEEE-1394a-2000
Controller (PHY/Link)
00:10.0 IDE interface: ALi Corporation M5229 IDE (rev c4)
00:11.0 Bridge: ALi Corporation M7101 PMU
00:12.0 Ethernet controller: National Semiconductor Corporation DP83815
(MacPhyter) Ethernet Controller
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility U1
Comment 4 Chris Ricker 2003-08-20 08:03:39 EDT
If I add

exclude irq 1
exclude irq 2
exclude irq 3
exclude irq 4
exclude irq 8
exclude irq 9
exclude irq 10
exclude irq 11
exclude irq 12
exclude irq 13
exclude irq 14
exclude irq 15

to /etc/pcmcia/config.opts it solves many of the problems. Interrupt routing issues?

Once I've added all the IRQ exclusions, I get the following behavior:

* insertion of the first card is not autodetected. I must use cardctl insert to
get the card seen. Once I've done that, if I cardctl eject and insert a new
card, or reinsert the same card, it's autodetected

* if an orinoco_cs is the first card inserted, it still hangs the system hard

* if I insert an e100 first, use it, eject it, then put in the orinoco_cs, it
usually (though not always ;-) works. Occasionally, that still hangs the system,
however
Comment 5 Luming Yu 2003-08-26 05:40:09 EDT
please attach output of acpidmp
Comment 6 Chris Ricker 2003-08-26 09:59:36 EDT
Created attachment 93934 [details]
acpidmp from the HP 4400 Pavilion

acpidmp output attached
Comment 7 Jun Nakajima 2003-08-27 01:12:18 EDT
Thanks for the dump data. Looks like this is a typical AML code. We should be 
able to reproduce this with our machines. 
Comment 8 shaohua li 2004-03-24 19:27:09 EST
please check if latest kernel resolve your problem. and please 
provide the dmesg and lspci output. thanks.
Comment 9 Chris Ricker 2004-03-24 19:51:20 EST
I can't, as I no longer have that laptop

Note You need to log in before you can comment on or make changes to this bug.