This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 1025698 - "dnf update" return bad response
"dnf update" return bad response
Status: CLOSED DUPLICATE of bug 1024776
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-01 06:31 EDT by nobrakal
Modified: 2013-11-01 06:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-01 06:41:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description nobrakal 2013-11-01 06:31:31 EDT
Description of problem:
I try to update my system with "dnf update" and it return:

Traceback (most recent call last):
  File "/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 277, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 133, in _main
    result, resultmsgs = cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1360, in run
    load_available_repos=lar)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 223, in activate_sack
    self._add_repo_to_sack(r.id)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 133, in _add_repo_to_sack
    repo.load()
  File "/usr/lib/python2.7/site-packages/dnf/repo.py", line 411, in load
    if self._try_revive():
  File "/usr/lib/python2.7/site-packages/dnf/repo.py", line 287, in _try_revive
    handle = self._handle_new_remote(tmpdir)
  File "/usr/lib/python2.7/site-packages/dnf/repo.py", line 207, in _handle_new_remote
    h.setopt(librepo.LRO_FASTESTMIRRORCACHE,
AttributeError: 'module' object has no attribute 'LRO_FASTESTMIRRORCACHE'

Version-Release number of selected component (if applicable):
I'm on Fedora 20 alpha, i686 release, with dnf 0.4.6

How reproducible:
Type "dnf update"
Comment 1 Zdeněk Pavlas 2013-11-01 06:41:16 EDT

*** This bug has been marked as a duplicate of bug 1024776 ***

Note You need to log in before you can comment on or make changes to this bug.