Bug 1025755 - I18N business-central in BPMS
I18N business-central in BPMS
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high
: ER1
: 6.0.2
Assigned To: Neus Miras
Marek Baluch
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-01 09:19 EDT by Toshiya Kobayashi
Modified: 2014-08-06 15:50 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 15:50:21 EDT
Type: Task
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kie-wb missing translations in Spanish (1.26 MB, application/octet-stream)
2013-12-16 06:28 EST, David Gutierrez
no flags Details
Japanese Translation issue (225.50 KB, application/msword)
2013-12-26 04:00 EST, Masahiko Umeno
no flags Details
Translation Snapshots (631.50 KB, application/x-zip-compressed)
2014-01-13 06:16 EST, Neus Miras
no flags Details
Missing translation in Ja language (136.50 KB, application/msword)
2014-01-13 06:38 EST, Neus Miras
no flags Details

  None (edit)
Description Toshiya Kobayashi 2013-11-01 09:19:12 EDT
Description of problem:

People can use business-central with translated texts.

Steps to Reproduce:
1. Go to http://localhost:8080/business-central/?locale=ja_JP
2. Login
3. Go through all pages

Actual results:

Texts are not translated.

Expected results:

(Almost) All texts are translated.

Additional info:

I find the following locales in community droolsjbpm master. I'm not sure if we can test all of these locales for 6.0.0 but at least ja_JP will be tested.

- de
- es_ES
- fr_FR
- ja_JP
- pt_BR
- zh_CN
Comment 1 Mauricio Salatino 2013-11-29 10:55:36 EST
Latest translations pushed to 6.0.x -> http://github.com/droolsjbpm/jbpm-console-ng/commit/434f8e56a I've tested with the Japanese translation and it's working ok. 
There some text that needs to be reviewed because they are still in english but at least the locales are working
Comment 5 David Gutierrez 2013-12-16 06:27:08 EST
Michael from RedHat BCN has cerried out a full overview of the tooling and has found some missing translation for the Spanish language (see attached zip with screenshots). Those translations need to be fixed in Spanish.
Comment 6 David Gutierrez 2013-12-16 06:28:02 EST
Created attachment 837216 [details]
kie-wb missing translations in Spanish
Comment 7 Masahiko Umeno 2013-12-26 04:00:26 EST
Created attachment 841789 [details]
Japanese Translation issue

This is a doc file for Japanese translator.
Comment 8 Masahiko Umeno 2013-12-26 04:04:27 EST
There are wrong translation and mismatching of behaviour. This is a quick review. I will try more deep review.
Comment 9 Neus Miras 2014-01-13 06:16:22 EST
Created attachment 849257 [details]
Translation Snapshots
Comment 10 Neus Miras 2014-01-13 06:33:29 EST
I have been reviewing the product and I found this general Translation issues:

Help Popups Popups_Help.png (all languages)
----------
Authoring:

Project Authoring

  New Item: -add translation for 'Bussiness Process' and 'Uploaded File' (img:1_Authoring_New.png)(All languages)

  Repository- add translation for 'Repository' and 'Categories Editor' (2_Authoring_projectAuthoring_Repository.png)(All languages)

  ProjectExplorer - Add translation to menu for changing display mode (3_Authoring_ProjectExplorer_changeview.png)(All languages)

  7_Authoring_assetMetadata.png the literal 'Documentation' -> (all languages)

Artifact Repository

  6_Authoring_Artifact_Repository.(All languages) 
	
Administration

  4_Authoring_Administration.pngFile Explorer (All languages)
  5_Authoring_Administration_CloneRepo in ES 'Repositorio de clones' -> 'Clonar repositorio' 

----------
Deploy

Deployment Units
  8_Deploy_DeploymentUnits.png (all languages)

Jobs
  9_Deploy_Jobs.png (all languages)

Problems panel.
  10_Problems  'Refresh' -> (all languages)

----------
Process Management

Process Definitions
11_ProcessManagement_ProcessDefinitions.png (all Languages)

Process Instances
12_ProcessManagement_processInstances.png (all languages)

----------

Tasks

Task list
13_Tasks_taskList.png (all languages)


The file attached Missing translationsJA.doc contain the remaining translations than can help with the missing literals.
Comment 11 Neus Miras 2014-01-13 06:38:27 EST
Created attachment 849260 [details]
Missing translation in Ja language
Comment 12 Neus Miras 2014-01-14 04:27:34 EST
I pushed at branding branch the home translations issues (JA) and Artifact repository literal change.
Commit
https://github.com/jboss-integration/kie-wb-distributions/commit/3b5f35888112fc16c4631f126b1d1682ede56dac
Comment 15 Neus Miras 2014-01-20 05:50:16 EST
the previous literal commits have been pushed to zanata too.
There are some remaining translations:
 
Authoring:

Project explorer
 New Item: -add translation for 'Bussiness Process' and 'Uploaded File' (img:1_Authoring_New.png)(All languages)

  Repository- add translation for 'Repository' and 'Categories Editor' (2_Authoring_projectAuthoring_Repository.png)(All languages)

  ProjectExplorer - Add translation to menu for changing display mode (3_Authoring_ProjectExplorer_changeview.png)(All languages)

  7_Authoring_assetMetadata.png the literal 'Documentation' -> (all languages)

Administration

  4_Authoring_Administration.pngFile Explorer (All languages)

Deploy

Deployment Units
  8_Deploy_DeploymentUnits.png (all languages)

Jobs
  9_Deploy_Jobs.png (all languages)

Problems panel.
  10_Problems  'Refresh' -> (all languages)

----------
Process Management

Process Definitions
11_ProcessManagement_ProcessDefinitions.png (all Languages)

Process Instances
12_ProcessManagement_processInstances.png (all languages)

----------

Tasks

Task list
13_Tasks_taskList.png (all languages)

These translations will managed at https://bugzilla.redhat.com/show_bug.cgi?id=1052858


Neus.
Comment 16 Toshiya Kobayashi 2014-01-29 04:48:45 EST
I have fixed some typo in HomeConstants for kie-wb/kie-drools-wb for locale=ja_JP in Zanata. Please pull when convenient for you.
Comment 17 Neus Miras 2014-01-29 10:41:57 EST
Done

Commit
prod-6.0.1.GA.x-2014.01.21
https://github.com/jboss-integration/kie-wb-distributions/commit/a869a26ce7c5d70c62fc79d35e6e33901f5931b7
Comment 18 Marek Baluch 2014-02-26 05:02:37 EST
Japan
1) Project explorer configuration menu is not translated yet.
  - includes Project View, Repository View, Show as Links, Show as Folders

Spanish
1) Process definitions
  - Search box contains still the string "search..."
2) Authoring -> Administration
  - No translation
3) Authoring -> Repository Artifacts
  - No translation
4) Explore -> 'Recently opened' and 'Recently edited'
  - Button "Refresh" is not translated
5) Authoring -> Asset Metadata
  - <documentation> is not translated (display a form and hit the Description tab)
6) 'Build & Deploy' project window
  - shows a force save dialog which has the following non-translated words: Information, Yes, No, Cancel
7) Create New Enumuration
  - Cancel button is not transalated (should be Cancelar)
8) Authoring -> Artifacts repository
  - No translation


German
Contains many translation issues - e.g. Home, Dashboards, etc.

Designer is missing translations too.
Comment 19 Neus Miras 2014-02-27 07:40:37 EST
It was remaining  a pull request, but now it has been done. I reviewe all this comments and the only remaining thing I see is the cancel button appears as no translated. Let me check the reason.
Comment 21 Neus Miras 2014-03-18 11:58:43 EDT
All translations commented are reviewed.
Comment 22 Marek Baluch 2014-04-29 05:38:46 EDT
Found a few little things but marking this issue as VERIFIED. No need to have a high severity/priority issue opened for small stuff. 

Verified on 6.0.2.ER2.

Note You need to log in before you can comment on or make changes to this bug.