Bug 102584 - licq does not start anymore
licq does not start anymore
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: licq (Show other bugs)
1.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-08-18 08:48 EDT by Mario Mikocevic
Modified: 2007-04-18 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-01 10:53:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mario Mikocevic 2003-08-18 08:48:31 EDT
Description of problem:
# licq
14:44:48: [ERR] Unable to load plugin (qt-gui):
/usr/X11R6/lib/tls/i686/libGL.so.1: cannot allocate memory in static TLS block.
14:44:48: [WRN] This usually happens when your plugin
      is not kept in sync with the daemon.
      Please try recompiling the plugin.
      If you are still having problems, see
      the FAQ at www.licq.org

Version-Release number of selected component (if applicable):
# rpm -qa | grep licq
licq-1.2.6-1
licq-qt-1.2.6-1

Additional info:
# rpmbuild --rebuild licq-1.2.6-1.src.rpm
..
icqd.cpp: In member function `ICQEvent* CICQDaemon::SendExpectEvent(ICQEvent*, 
   void*(*)(void*))':
icqd.cpp:1096: error: invalid conversion from `ICQEvent*' to `long int'
make[2]: *** [icqd.o] Error 1
make[2]: Leaving directory `/usr/src/redhat/BUILD/licq-1.2.6/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/licq-1.2.6'
make: *** [all] Error 2

??
Comment 1 Jan Pazdziora 2003-08-20 05:15:54 EDT
Confirm failure for version 1.2.6-1, for the qt-gui plugin. The same problem
persists with liqc 1.2.7, downloaded from www.licq.org (the packages there
are licq-base-1.2.7-1 and licq-qt-gui-1.2.7-1). Upgrade of XFree86-Mesa-libGLU*
did not help either.

Versions of other packages that may be relevant:

XFree86-Mesa-libGL-4.3.0-20
XFree86-Mesa-libGLU-4.3.0-20
XFree86-libs-data-4.3.0-20
XFree86-4.3.0-20
XFree86-libs-4.3.0-20

On the other hand, licq with gtk frontend (licq -p jons-gtk-gui) runs
alright.
Comment 2 Thomas Woerner 2003-09-01 10:53:49 EDT
I am sorry, I can not reproduce this error on severn.
Comment 3 Jan Pazdziora 2003-09-01 11:53:33 EDT
Well, how do you expect us to respond to this? It doesn't work for
me on toady's RawHide, aka Severn. So closing it seems vastly premature
-- the only result will be that we will have to open new bug, with the
same content.

Could you at least provide list of relevant rpms you have? Are you sure
you're running Qt frontend?
Comment 4 Jan Pazdziora 2003-09-01 12:03:43 EDT
Sorry, I sent out the message too fast. I meant to say Raw Hide aka Severn +.

If I understand the purpose and status of Raw Hide correctly, it's newer
than Severn. So the fact that it works for you in Severn means that
something got broken after Severn was tagged. Raw Hide is newer, not older.
So if it's broken in Raw Hide, it will be broken in you next release, unless
fixed.
Comment 5 Thomas Woerner 2003-09-01 12:58:36 EDT
licq -p qt-gui woks for me without any error.

These are the requires of licq and licq-qt on my system (severn++,
kernel-2.4.21-20.1.2024.2.1.nptl):

glibc-2.3.2-78
htmlview-2.0.0-10
libgcc-3.3.1-1
libstdc++-3.3.1-1
ncurses-5.3-7
perl-5.8.1-90.rc4.0
qt-3.1.2-14
XFree86-libs-4.3.0-20

It workes with XFree86-libs-4.3.0-22.1, too. I can also rebuild licq.


By the way - you can reopen a bug report ...
Comment 6 Jan Pazdziora 2003-09-01 13:09:28 EDT
I have exactly those versions of rpms and still get the same errors

$ licq -p qt-gui
-p qt-gui
19:03:52: [WRN] Licq: Ignoring stale lockfile (pid 2416)
19:03:52: [ERR] Unable to load plugin (qt-gui): /usr/lib/tls/i686/libGL.so.1:
cannot allocate memory in static TLS block.
19:03:52: [WRN] This usually happens when your plugin
      is not kept in sync with the daemon.
      Please try recompiling the plugin.
      If you are still having problems, see
      the FAQ at www.licq.org

However, I'm running vanilla 2.4.21 kernel. I'll try to get RH kernel and
see if it makes any difference.

I don't think I can reopen the bug as I'm not the original reporter.

Thanks.
Comment 7 Jan Pazdziora 2003-09-01 13:26:17 EDT
Upgraded kernel to the version you state, rebooted, licq runs alright.

Thank you once more.
Comment 8 Mario Mikocevic 2003-09-02 03:18:02 EDT
Stay cool !
I am not reopening the bug :)
Just wanted to aknowledge that I also use Linus's kernels so it looks like licq
(or any libGL ?)
does not want to work with them. It's probably from lacking proper dri/drm
version in kernel.
Is there a single patch just to update drm in Linus's kernels ?

Note You need to log in before you can comment on or make changes to this bug.