Bug 102594 - Viewing multi-lingual items sometimes gives 404
Viewing multi-lingual items sometimes gives 404
Status: CLOSED DUPLICATE of bug 102431
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: ccm-bugs-list
Jon Orris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-18 10:43 EDT by Randy Graebner
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randy Graebner 2003-08-18 10:43:23 EDT
Description of problem:
It is possible for a user to see a 404 if they do not have the correct settings
in their browser.  For instance, if I create a multi-lingual item in three
languages: French, German, and Spanish and my browser only has English under the
"Edit -> preferences -> Languages" then going to the url
(/ccm/content/myfolder/my-multi-lingual-item) will give a 404.  However, if I
add any of the three appropriate languages to my browser and then reload the
page then the item will load.

I propose that, if the user does not have a language in their header that
matches an available language, the system should server the item using the
default language for the Content Bundle instead of giving a 404.  


Version-Release number of selected component (if applicable):
Nightly

How reproducible:
Always

Steps to Reproduce:
1.  Create a content item and make the primary instance use a language that is
not in your language preferences.
2.  Load the page and get the 404.
3.  Add the language to your preference and reload the page and you will see you
 no longer get the 404.
    
Actual results:
404

Expected results:
default content item

Additional info:
This will need to be fixed for Carrefour by the end of August...it would be nice
to have an official engineering solution rather than a one off solution.
Comment 1 Randy Graebner 2003-11-04 09:24:05 EST

*** This bug has been marked as a duplicate of 102431 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:08 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.