Bug 1025952 - hybrid crawl does not sync symlinks (and error's out)
hybrid crawl does not sync symlinks (and error's out)
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
:
Depends On: 1036539
Blocks: 1025954
  Show dependency treegraph
 
Reported: 2013-11-02 09:15 EDT by Venky Shankar
Modified: 2014-12-28 23:54 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1025954 (view as bug list)
Environment:
Last Closed: 2014-12-28 23:54:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Venky Shankar 2013-11-02 09:15:55 EDT
Description of problem:
Initall (one-shot) hybrid crawl does not correctly process symlinks if found and error's out, thereby geo-replication's status becomes faulty.

Version-Release number of selected component (if applicable):
mainline

How reproducible:
always
Comment 1 Anand Avati 2013-11-02 10:41:16 EDT
REVIEW: http://review.gluster.org/6215 (gsyncd / geo-rep: fix symlink handling in hybrid crawl) posted (#1) for review on master by Venky Shankar (vshankar@redhat.com)
Comment 2 Aravinda VK 2014-12-28 23:54:50 EST
The patch http://review.gluster.org/#/c/6404/ fixes this issue as part of bz 1036539

Note You need to log in before you can comment on or make changes to this bug.