This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1025954 - Dist-geo-rep : hybrid crawl does not sync symlinks (and error's out)
Dist-geo-rep : hybrid crawl does not sync symlinks (and error's out)
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Bug Updates Notification Mailing List
Vijaykumar Koppad
: ZStream
Depends On: 1025952
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-02 09:17 EDT by Venky Shankar
Modified: 2014-08-24 20:50 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.39rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1025952
Environment:
Last Closed: 2013-11-27 10:45:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Venky Shankar 2013-11-02 09:17:17 EDT
+++ This bug was initially created as a clone of Bug #1025952 +++

Description of problem:
Initall (one-shot) hybrid crawl does not correctly process symlinks if found and error's out, thereby geo-replication's status becomes faulty.

Version-Release number of selected component (if applicable):
mainline

How reproducible:
always
Comment 3 Gowrishankar Rajaiyan 2013-11-11 05:31:19 EST
Please provide steps to verify.
Comment 4 Venky Shankar 2013-11-11 06:04:51 EST
Steps to verify:

1. Create and start a GlusterFS volume and mount it
2. Create some softlinks on the mount
3. Create and start a geo-replication session
4. Geo-replication should not crash while syncing the symlinks
Comment 5 Vijaykumar Koppad 2013-11-15 06:47:23 EST
Verified on the build glusterfs-3.4.0.44rhs, 

Steps followed,

1.create and start a geo-rep relationship between master and slave.
2.create some files on master and sync the files.
3.stop the geo-rep
4.create symlinks to all those files.
5.start geo-reo rep, and check if it syncs symlinks.
Comment 6 errata-xmlrpc 2013-11-27 10:45:50 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.