Bug 102613 - mutt segfaults when I try to send a reply to a particular message
Summary: mutt segfaults when I try to send a reply to a particular message
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: slang   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact:
URL: http://www.csi.hu/mw/mutt-bug.tgz
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-18 18:05 UTC by Mate Wierdl
Modified: 2007-04-18 16:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-12 19:45:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mate Wierdl 2003-08-18 18:05:26 UTC
Description of problem:
In short: mutt segfaults when I try to send a reply to the message
in the Maildir included in the tar file above.  The problem is
completely reproducible on both of my RedHat 9 systems.

Version-Release number of selected component (if applicable):
mutt-1.4.1-3.2

Note that my system has 

$ rpm -q slang slang-devel
slang-1.4.5-18.1
slang-devel-1.4.5-18.1

since I had problems with mutt related to a bug in the slang libraries 
on RH 9.

How reproducible:

Always

Steps to Reproduce:
1. 
tar zxvf mutt-bug.tgz; cd mutt-bug

2.
./load_mutt.sh

3.

Press `r' to reply to the message. When I press `y' to send out
the reply, I get
                                                                                
Sending message..../load_mutt.sh: line 3: 32661 Segmentation fault      mutt
-n\f Maildir -F mymuttrc
    

Additional info:

This tarball includes a maildir with a message in it, a strace output,
the output of `mutt -v', and a muttrc file called mymuttrc--which is
empty.

Comment 1 Bill Nottingham 2003-08-18 18:10:48 UTC
Hm, works for me, although I edited the reply-to.

Comment 2 Bill Nottingham 2003-08-18 18:11:34 UTC
Note that the strace included isn't of the mutt process itself.

Comment 3 Bill Nottingham 2003-08-18 18:15:09 UTC
OK, reproduced. Fun. Appears to be random memory corruption somewhere.

Comment 4 Bill Nottingham 2003-08-18 18:21:57 UTC
slang's waddch is writing outside the screen buffer.

Comment 5 Bill Nottingham 2003-08-18 18:22:47 UTC
(when it's formatting the reply-to: prompt)

Comment 6 Bill Nottingham 2003-08-18 19:41:25 UTC
Will be tangentially fixed in mutt-1.4.1-4 by building with ncursesw, but that
doesn't solve the underlying slang issue.

Comment 7 Mate Wierdl 2003-08-19 02:31:15 UTC
Yeah, I messed up the strace run, but now updated the tarball with a correct
strace_out.  And the point is, as you noticed, to _not_ change the return address.

Hope you have a copy of the tarball of the URL above because our university's
network has been disabled by a worm/DOS.

Comment 8 Eido Inoue 2004-11-12 19:45:18 UTC
slang-1.4.9 on the latest releases seems to have resolved the issue
with  waddch()


Note You need to log in before you can comment on or make changes to this bug.