Bug 1026227 - quota: volume stop leaves the volume mount with "Transport endpoint is not connected"
quota: volume stop leaves the volume mount with "Transport endpoint is not co...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: quota (Show other bugs)
2.1
x86_64 Linux
medium Severity medium
: ---
: RHGS 3.0.0
Assigned To: Susant Kumar Palai
Saurabh
:
: 1034880 (view as bug list)
Depends On:
Blocks: 1049323
  Show dependency treegraph
 
Reported: 2013-11-04 03:57 EST by Saurabh
Modified: 2016-09-17 08:42 EDT (History)
11 users (show)

See Also:
Fixed In Version: glusterfs-3.6.0.5-1.el6rhs
Doc Type: Bug Fix
Doc Text:
Previously, stopping a volume would display the message - "Transport end point not connected state" in the quota auxiliary mount. With this fix, quota auxiliary mount is unmounted after the volume stop command is executed.
Story Points: ---
Clone Of:
: 1049323 (view as bug list)
Environment:
Last Closed: 2014-09-22 15:29:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:1278 normal SHIPPED_LIVE Red Hat Storage Server 3.0 bug fix and enhancement update 2014-09-22 19:26:55 EDT

  None (edit)
Description Saurabh 2013-11-04 03:57:59 EST
Description of problem:
Once the quota is enabled and limit set.
First time executing the gluster volume quota $volname list" is executed, a glusterfs mount is created on the server for that particular volume. 

Problem is, even when this volume is stopped, glusterfs mount for that volume still exists and "df -h" displays, "Transport endpoint is not connected"


Version-Release number of selected component (if applicable):
glusterfs-3.4.0.38rhs-1

How reproducible:
always

Steps to Reproduce:
1. enable quota on a volume, set some limit on "/" of the volume
2. gluster volume quota $volume list
3. df -h
4. gluster volume stop $volname
5. df -h

Actual results:
step3, a new mount related to $volname can be seen.
step5. reports "Transport endpoint is not connected" for that same mount

Expected results:
I would like to have a umount been done when a volume is stopped

Additional info:
Comment 2 Saurabh 2013-11-14 04:23:40 EST
The problem I am facing with this issue is that, once the volume is stopped and deleted. The mount-point is still there.

If I create a new volume with the same name, now being the information of that same name is still there, hence the gluster volume quota $volname fails, 


as can be seen with the example.

[root@quota7 ~]# gluster volume quota dist-rep list
quota: Could not start quota auxiliary mount
[root@quota7 ~]# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/mapper/vg_quota7-lv_root
                       42G  6.3G   33G  17% /
tmpfs                 4.0G     0  4.0G   0% /dev/shm
/dev/vda1             485M   52M  408M  12% /boot
df: `/var/run/gluster/dist-rep': Transport endpoint is not connected
df: `/var/run/gluster/dist-rep1': Transport endpoint is not connected
/dev/mapper/RHS_vgvdb-RHS_lv1
                      1.5T   36M  1.5T   1% /rhs/brick1
/dev/mapper/RHS_vgvdc-RHS_lv2
                      1.6T   35M  1.6T   1% /rhs/brick2


Here the volume in consideration are dist-rep and dist-rep1
 
and the command "gluster volume quota dist-rep list" failed because of earlier mount info is still there.

Now, it works only if I manually do a "umount".

This is not ok from user experience point of view.
Comment 3 Sudhir D 2013-11-27 23:08:00 EST
*** Bug 1034880 has been marked as a duplicate of this bug. ***
Comment 4 Susant Kumar Palai 2014-01-31 22:19:09 EST
Upstream Fix : http://review.gluster.org/6656
Comment 5 Vivek Agarwal 2014-05-22 07:11:48 EDT
Marking for denali as it got merged as a part of the rebase
Comment 6 Susant Kumar Palai 2014-05-22 07:18:25 EDT
Fixed in version : glusterfs-3.6.0.5-1.el6rhs
Comment 7 Saurabh 2014-06-19 07:09:02 EDT
[root@nfs1 ~]# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/mapper/vg_nfs1-lv_root
                       50G  1.9G   45G   4% /
tmpfs                 4.0G     0  4.0G   0% /dev/shm
/dev/vda1             485M   34M  426M   8% /boot
/dev/mapper/vg_nfs1-rhs
                      425G  3.1G  422G   1% /bricks
localhost:dist-rep    2.5T   16G  2.5T   1% /var/run/gluster/dist-rep
[root@nfs1 ~]# gluster volume stop dist-rep
Stopping volume will make its data inaccessible. Do you want to continue? (y/n) y
volume stop: dist-rep: success
[root@nfs1 ~]# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/mapper/vg_nfs1-lv_root
                       50G  1.9G   45G   4% /
tmpfs                 4.0G     0  4.0G   0% /dev/shm
/dev/vda1             485M   34M  426M   8% /boot
/dev/mapper/vg_nfs1-rhs
                      425G  3.1G  422G   1% /bricks


Hence, moving the BZ to verified
Comment 8 Pavithra 2014-07-23 05:21:42 EDT
Hi Susant,

Please review the edited doc text for technical accuracy and sign off.
Comment 9 Susant Kumar Palai 2014-09-15 07:27:38 EDT
Doc looks good to me.
Comment 11 errata-xmlrpc 2014-09-22 15:29:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1278.html

Note You need to log in before you can comment on or make changes to this bug.