Bug 1034880 - [RFE] Stopping Gluster Volume while Quotas are Enabled Causes a Stale Mount
Summary: [RFE] Stopping Gluster Volume while Quotas are Enabled Causes a Stale Mount
Status: CLOSED DUPLICATE of bug 1026227
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs   
(Show other bugs)
Version: 2.1
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Raghavendra G
QA Contact: Sudhir D
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-26 16:17 UTC by Aron Gunn
Modified: 2014-06-09 14:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-28 04:08:00 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Aron Gunn 2013-11-26 16:17:44 UTC
Description of problem:
When stopping the Gluster volume before disabling quota on the volume will generate a 'df' error.

Version-Release number of selected component (if applicable):
glusterfs-server-3.4.0.35rhs-1.el6rhs.x86_64

How reproducible:
Consistently

Steps to Reproduce:
-Volume layout:
[root@rhsn1 ~]# gluster volume info
 
Volume Name: dist_test_vol01
Type: Distribute
Volume ID: d7aeb433-4b3e-4c29-ae09-bf956f11c10d
Status: Started
Number of Bricks: 2
Transport-type: tcp
Bricks:
Brick1: rhsn1:/rhs/brick01/vol01
Brick2: rhsn3:/rhs/brick01/vol01

-Enable quota on a volume:
[root@rhsn1 ~]# gluster volume quota dist_test_vol01 enable
volume quota : success

Volume Name: dist_test_vol01
Type: Distribute
Volume ID: d7aeb433-4b3e-4c29-ae09-bf956f11c10d
Status: Started
Number of Bricks: 2
Transport-type: tcp
Bricks:
Brick1: rhsn1:/rhs/brick01/vol01
Brick2: rhsn3:/rhs/brick01/vol01
Options Reconfigured:
features.quota: on

-A local FUSE mount is created:
[root@rhsn1 ~]# df -Ph
Filesystem            Size  Used Avail Use% Mounted on
...
localhost:dist_test_vol01 1015M  534M  482M  53% /tmp/dist_test_vol01

[root@rhsn1 ~]# mount
...
localhost:dist_test_vol01 on /tmp/dist_test_vol01 type fuse.glusterfs (rw,default_permissions,allow_other,max_read=131072)

-Stop the volume:
[root@rhsn1 ~]# gluster volume stop dist_test_vol01
Stopping volume will make its data inaccessible. Do you want to continue? (y/n) y
volume stop: dist_test_vol01: success

-Output from 'df':
[root@rhsn1 ~]# df -Ph
Filesystem            Size  Used Avail Use% Mounted on
...
df: `/tmp/dist_test_vol01': Transport endpoint is not connected

Actual results:
No warning when stopping the Gluster volume.
df: `/tmp/dist_test_vol01': Transport endpoint is not connected

Expected results:
Provide a warning that if the Gluster volume is stopped (while quotas are enabled), the quota features may not work properly, but still stop the Gluster volume.  Maybe something similar to a busy mount point warning.

Comment 1 Saurabh 2013-11-27 06:16:20 UTC
A similar BZ 1026227 already exists.
How about moving this bz to be a duplicate of the one already exists?

Comment 2 Vivek Agarwal 2013-11-27 07:36:53 UTC
Close the other one as duplicate, reason being this has a customer case attached to it.

Comment 3 Raghavendra G 2013-11-27 11:14:11 UTC
Aron,

May be we can unmount the auxiliary mount point while stopping the volume and remount once we start it. Does it sound reasonable?

regards,
Raghavendra.

Comment 4 Sudhir D 2013-11-28 04:08:00 UTC

*** This bug has been marked as a duplicate of bug 1026227 ***

Comment 5 Aron Gunn 2014-06-09 14:31:49 UTC
(In reply to Raghavendra G from comment #3)
> Aron,
> 
> May be we can unmount the auxiliary mount point while stopping the volume
> and remount once we start it. Does it sound reasonable?
> 
> regards,
> Raghavendra.

Raghavendra,

I know it's closed now and sorry for the extended delay in my response.  Yes, that sounds reasonable.

Thanks,
Aron


Note You need to log in before you can comment on or make changes to this bug.