Bug 1026236 - VLAN devices are displayed in the setup networks dialog and nics subtab, cause all setup networks operations to fail
VLAN devices are displayed in the setup networks dialog and nics subtab, caus...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity low
: ---
: 3.4.0
Assigned To: Antoni Segura Puimedon
network
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 04:05 EST by Assaf Muller
Modified: 2016-02-10 14:51 EST (History)
14 users (show)

See Also:
Fixed In Version: ovirt-3.4.0-alpha1
Doc Type: Bug Fix
Doc Text:
Previously, VDSM would report non-virtual machine VLAN networks attached to network devices and the Red Hat Enterprise Virtualization Manager would display that VLAN device in the Administration Portal. However, subsequent calls to the setupNetworks action would then fail. This was caused by the logic used to report VLAN devices, which has now been revised so that VLAN devices are reported correctly and subsequent calls to the setupNetworks action succeed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-09 09:26:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21054 None None None Never

  None (edit)
Description Assaf Muller 2013-11-04 04:05:44 EST
Description of problem:
After attaching a non-VM, vlanned network to a network device, VDSM reports the new vlan device (As usual) and the engine displays the new vlan device in the different GUI elements. Subsequent setupNetworks will fail with a 'network sent twice' error. In other words, if a non-VM, vlanned network is placed on a host, the host's networking will no longer be able to be managed by the engine, until the network is manually removed from the host.

How reproducible:
100%

Steps to Reproduce:
1. Create a new, non-VM, vlanned network
2. Attach it to a bond / nic

Actual results:
Following a successful operation, the new VLAN device will be visible in the GUI

Expected results:
The VLAN device should not be visible in the GUI

Additional info:
I reproduced the issue with a dummy nic. However, I suspect the bug has nothing to do with dummy nics.
Comment 1 Lior Vernia 2013-11-04 04:11:35 EST
Moti, I think this has to do with the fix we discussed a couple of months ago for Bug 1011486.
Comment 2 Assaf Muller 2013-11-05 10:01:30 EST
After Moti debugged it for a bit he discovered that this indeed only happens with dummy nics, and it's a VDSM bug.

As it turns out in vdsCaps, the dummy nic and vlan device are both reported under the nics section (Which is wrong, and different than with real / non-dummy devices).
Comment 3 Meni Yakove 2014-01-29 03:41:24 EST
ovirt-engine-3.4.0-0.5.beta1.el6.noarch
Comment 6 errata-xmlrpc 2014-06-09 09:26:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0504.html

Note You need to log in before you can comment on or make changes to this bug.