Bug 1026464 - [RFE] remember search string, selected item and active sub-tab on main tab switching; highlight non-default search text
[RFE] remember search string, selected item and active sub-tab on main tab sw...
Status: CLOSED DUPLICATE of bug 878129
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.4.0
Assigned To: nobody nobody
Pavel Stehlik
: FutureFeature, Improvement, Triaged
Depends On:
  Show dependency treegraph
Reported: 2013-11-04 12:42 EST by David Jaša
Modified: 2014-02-03 06:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2014-01-08 10:33:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description David Jaša 2013-11-04 12:42:09 EST
Description of problem:
When working with a subset of resources (say VMs) in webadmin, it's quite handy to have the rest filtered out by search - till you have to switch to other main tab. When you return back, you're at default view once again and you have to retype the search and probably also select the item you had had opened - not cool...

Version-Release number of selected component (if applicable):
3.3 (is20.2)

How reproducible:

Steps to Reproduce:
1. enter search in main search box, select one of items, select some non-default sub tab
2. change main tab
3. go back to main tab from point 1.

Actual results:
default view is displayed

Expected results:
display should match the one after point 1.

Additional info:
search entry background should be changed based on the content to give user visual indication that the view is in non-default state. A color key could probably be:
* gray: default (no search active)
* yellow: search typed but not commited
* red: invalid search term
* green: search active

I don't consider this a full-blown feature as it seems to me quite minor change in terms of code and the current behaviour is not very ergonomic...
Comment 1 Einav Cohen 2014-01-08 10:33:49 EST

*** This bug has been marked as a duplicate of bug 878129 ***

Note You need to log in before you can comment on or make changes to this bug.