Bug 1026572 - [ALL_lang] Some of the fileds in the Instance Console are not localized
[ALL_lang] Some of the fileds in the Instance Console are not localized
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: novnc (Show other bugs)
4.0
Unspecified Unspecified
medium Severity unspecified
: ---
: 5.0 (RHEL 7)
Assigned To: RHOS Maint
yeylon@redhat.com
: i18n, Triaged, ZStream
: 1026575 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 20:25 EST by Mie Yamamoto
Modified: 2016-04-18 02:59 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 10:23:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Some fields not localized in the Instance console page (178.55 KB, image/png)
2013-11-04 20:25 EST, Mie Yamamoto
no flags Details

  None (edit)
Description Mie Yamamoto 2013-11-04 20:25:39 EST
Created attachment 819432 [details]
Some fields not localized in the Instance console page

Description of problem:
Some of the fileds in the Instance Console are not localized
1)Connected (unencrypted) to: QEMU (instance-00000002)
2)Send Ctrl-Alt-Del button
3)Instance Detail

Version-Release number of selected component (if applicable): 4.0


How reproducible: 100%


Steps to Reproduce:
1.Click on Admin-System Panel-Instances tab from the left side panel
2. click drop-down list (Console)
3. Some of the fields are not localized

Actual results:
1)Connected (unencrypted) to: QEMU (instance-00000002)
2)Send Ctrl-Alt-Del button
3)Instance Detail

Expected results:
1)接続先 (暗号化なし): QEMU (instance-00000002)
2)Ctrl-Alt-Delの送信
3)インスタンスの詳細

Additional info:
Screen shot attached
Comment 2 Yuko Katabami 2013-11-04 22:38:32 EST
*** Bug 1026575 has been marked as a duplicate of this bug. ***
Comment 3 Julie Pichon 2013-11-12 11:20:35 EST
Thanks for the report.

It seems these strings live in the noVNC repository, outside of Horizon. They are not marked as translatable and there doesn't seem to be a mechanism to handle non-English locales in noVNC at the moment. This will require more work.

The untranslated 'Instances Details' is on us and should be easy to fix. It looks like there was a change between 'Instance Detail' and 'Instance Details' and that caused the translation to be "lost."
Comment 4 Julie Pichon 2013-11-14 10:53:39 EST
On the Horizon side, "Instance Detail: " was not marked as translatable, this is fixed in Icehouse.

I'm moving this bug to noVNC for assessing the internationalisation effort.

Note You need to log in before you can comment on or make changes to this bug.