Bug 1026646 - Better to disable "enter" button works for the fan status table of ipmi page
Better to disable "enter" button works for the fan status table of ipmi page
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
low Severity low
: ---
: 3.4.1
Assigned To: Ryan Barry
bugs@ovirt.org
node
:
Depends On:
Blocks: 1026647
  Show dependency treegraph
 
Reported: 2013-11-05 02:07 EST by haiyang,dong
Modified: 2014-04-30 07:03 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1026647 (view as bug list)
Environment:
Last Closed: 2014-04-30 07:03:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attached Screenshot for hang page (15.34 KB, image/png)
2013-11-05 02:07 EST, haiyang,dong
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21929 None None None Never

  None (edit)
Description haiyang,dong 2013-11-05 02:07:06 EST
Created attachment 819545 [details]
attached Screenshot for hang page

Description of problem:
Using "edit-node --repo=edit-node.repo --install=ovirt-node-plugin-ipmi-3.1.0-0.999.20131105052117git6b9cff5.el6.noarch.rpm ovirt-node-iso-3.1.0-0.999.1181.el6.iso
" to install ipmi plugin into rhev-h.
It will install ovirt-node-plugin-ipmi ipmitool OpenIPMI and OpenIPMI-libs package.
Then clean install this edited iso on DELL PowerEdge R510,login rhev-h.
Enter into IPMI page and check that the "IPMI Enabled" show "True" and Fan Status also was shown in IPMI page.

But the "enter" button works for the fan status table of ipmi page, if users selected one item of the fan status table
and click "enter" button, rhev-h will hang on(Seen hang page.png).
Also "enter" button works wasn't necessary for the fan status table of ipmi page,
so it's better to disable "enter" button works for the fan status table of ipmi page

Version-Release number of selected component (if applicable):
ovirt-node-iso-3.1.0-0.999.1181.el6.iso
ovirt-node-plugin-ipmi-3.1.0-0.999.20131105052117git6b9cff5.el6.noarch.rpm

How reproducible:
100%

Steps to Reproduce:

Actual results:


Expected results:

Additional info:
Comment 1 Ryan Barry 2013-12-02 13:48:07 EST
I wasn't able to actually reproduce a hang on an R300, though that's definitely output from "ipmitool -E open chassis status", and it looks like it may have been passed through to stdout.

I was able to make the UI scroll off the screen by pressing enter (though the arrow keys still responded and I was able to change screens as normal).

I don't see a clean way to resolve disabling input on a Table by Table basis, and changing the codebase to add parameters for something which is only problematic here and readily resolved by catching the output seems intrusive.

That said, if this patch doesn't resolve or it's otherwise desirable to add the ability to disable input on TableEntries, I'll definitely investigate it.
Comment 2 Sandro Bonazzola 2014-03-04 04:18:59 EST
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.

Note You need to log in before you can comment on or make changes to this bug.