Bug 1026647 - Better to disable "enter" button works for the fan status table of ipmi page
Better to disable "enter" button works for the fan status table of ipmi page
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Ryan Barry
Virtualization Bugs
:
Depends On: 1026646
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-05 02:08 EST by haiyang,dong
Modified: 2014-06-09 10:05 EDT (History)
18 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-8.el6
Doc Type: Bug Fix
Doc Text:
Previously, output from the IPMI plugin was being displayed, and gave the appearance of 'hanging' if enter was pressed. The output is no longer displayed.
Story Points: ---
Clone Of: 1026646
Environment:
Last Closed: 2014-01-21 14:36:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rbarry: needinfo-


Attachments (Terms of Use)

  None (edit)
Description haiyang,dong 2013-11-05 02:08:15 EST
+++ This bug was initially created as a clone of Bug #1026646 +++

Description of problem:
Using "edit-node --repo=edit-node.repo --install=ovirt-node-plugin-ipmi-3.1.0-0.999.20131105052117git6b9cff5.el6.noarch.rpm ovirt-node-iso-3.1.0-0.999.1181.el6.iso
" to install ipmi plugin into rhev-h.
It will install ovirt-node-plugin-ipmi ipmitool OpenIPMI and OpenIPMI-libs package.
Then clean install this edited iso on DELL PowerEdge R510,login rhev-h.
Enter into IPMI page and check that the "IPMI Enabled" show "True" and Fan Status also was shown in IPMI page.

But the "enter" button works for the fan status table of ipmi page, if users selected one item of the fan status table
and click "enter" button, rhev-h will hang on(Seen hang page.png).
Also "enter" button works wasn't necessary for the fan status table of ipmi page,
so it's better to disable "enter" button works for the fan status table of ipmi page

Version-Release number of selected component (if applicable):
ovirt-node-iso-3.1.0-0.999.1181.el6.iso
ovirt-node-plugin-ipmi-3.1.0-0.999.20131105052117git6b9cff5.el6.noarch.rpm

How reproducible:
100%

Steps to Reproduce:

Actual results:


Expected results:

Additional info:
Comment 1 haiyang,dong 2013-11-05 02:10:35 EST
can reproduce it in ovirt-node-plugin-ipmi-3.0.1-7.el6.noarch.rpm,so need to clone it from upstream to track it in rhev-h
Comment 3 RHEL Product and Program Management 2013-11-09 03:15:06 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 Ryan Barry 2013-12-02 13:52:43 EST
I wasn't able to actually reproduce a hang on an R300, though that's definitely output from "ipmitool -E open chassis status", and it looks like it may have been passed through to stdout.

I was able to make the UI scroll off the screen by pressing enter (though the arrow keys still responded and I was able to change screens as normal).

I don't see a clean way to resolve disabling input on a Table by Table basis, and changing the codebase to add parameters for something which is only problematic here and readily resolved by catching the output seems intrusive.

That said, if this patch doesn't resolve or it's otherwise desirable to add the ability to disable input on TableEntries, I'll definitely investigate it.
Comment 6 Cheryn Tan 2014-01-08 00:37:16 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:
https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thank you for your help.
Comment 7 haiyang,dong 2014-01-13 21:07:52 EST
Test version:
ovirt-node-plugin-ipmi-3.0.1-15.el6_5.noarch.rpm
ovirt-node-3.0.1-15.el6_5.noarch.rpm 
rhevh-6.5-20140109.0.iso

Using "edit-node --repo=edit-node.repo --install=oovirt-node-plugin-ipmi-3.0.1-15.el6_5.noarch.rpm rhevh-6.5-20140109.0.iso
" to install ipmi plugin into rhev-h.
It will install ovirt-node-plugin-ipmi ipmitool OpenIPMI and OpenIPMI-libs package.
Then clean install this edited iso on DELL PowerEdge R510,login rhev-h.
Enter into IPMI page and check that the "IPMI Enabled" show "True" and Fan Status also was shown in IPMI page.

Now "enter" button didn't work for the fan status table of ipmi page,
so this bug has been fixe, change the status into "verified"
Comment 9 errata-xmlrpc 2014-01-21 14:36:57 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.