Bug 1026750 - perl.req produces bogus dependencies
Summary: perl.req produces bogus dependencies
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rpm
Version: 6.4
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Packaging Maintenance Team
QA Contact: Marek Marusic
URL:
Whiteboard:
Depends On:
Blocks: 994246 1075802
TreeView+ depends on / blocked
 
Reported: 2013-11-05 11:09 UTC by Konstantin Lepikhov
Modified: 2019-08-15 03:42 UTC (History)
10 users (show)

Fixed In Version: rpm-4.8.0-40.el6
Doc Type: Bug Fix
Doc Text:
Under certain circumstances, the rpm utility incorrectly required the /proc file system to be mounted, and using rpm failed with the following error: warning: Failed to read auxiliary vector, /proc not mounted? With this update, the /proc file system is only required for appropriate RPM operations, and the described failure no longer occurs.
Clone Of:
: 1191124 (view as bug list)
Environment:
Last Closed: 2015-07-22 07:03:02 UTC


Attachments (Terms of Use)
example code for testing (32.31 KB, text/plain)
2013-11-05 11:10 UTC, Konstantin Lepikhov
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1452 normal SHIPPED_LIVE rpm bug fix and enhancement update 2015-07-20 18:43:47 UTC

Description Konstantin Lepikhov 2013-11-05 11:09:39 UTC
Description of problem:
Parser that generates rpm "Requires:" can generate fake dependencies in case it finds "use something" string in the script. 

Version-Release number of selected component (if applicable):
rpm-4.8.0-32.el6.x86_64

How reproducible:
Always 

Steps to Reproduce:
$ /usr/lib/rpm/perl.req ./mysql_install_db

Actual results:
perl(Data::Dumper)
perl(Fcntl)
perl(File::Basename)
perl(File::Copy)
perl(Getopt::Long)
perl(Sys::Hostname)
perl(hostnames)
perl(strict)


Expected results:
perl(Data::Dumper)
perl(Fcntl)
perl(File::Basename)
perl(File::Copy)
perl(Getopt::Long)
perl(Sys::Hostname)
perl(strict)

Additional info:
$ yum search perl\(hostnames\)Loaded plugins: langpacks, refresh-packagekit
Warning: No matches found for: perl(hostnames)
No matches found

Comment 1 Konstantin Lepikhov 2013-11-05 11:10:30 UTC
Created attachment 819659 [details]
example code for testing

Comment 6 Florian Festi 2014-12-15 12:26:48 UTC
Patch available upstream

Comment 12 errata-xmlrpc 2015-07-22 07:03:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1452.html


Note You need to log in before you can comment on or make changes to this bug.