Bug 1191124 - perl.req produces bogus dependencies
Summary: perl.req produces bogus dependencies
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rpm
Version: 7.1
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Florian Festi
QA Contact: Karel Srot
URL:
Whiteboard:
Depends On:
Blocks: 1337389
TreeView+ depends on / blocked
 
Reported: 2015-02-10 13:53 UTC by Marek Marusic
Modified: 2019-08-15 04:15 UTC (History)
2 users (show)

Fixed In Version: rpm-4.11.3-1.el7
Doc Type: Bug Fix
Doc Text:
Under certain circumstances, the rpm utility incorrectly required the /proc file system to be mounted, and using rpm failed with the following error: warning: Failed to read auxiliary vector, /proc not mounted? With this update, the /proc file system is only required for appropriate RPM operations, and the described failure no longer occurs.
Clone Of: 1026750
: 1337389 (view as bug list)
Environment:
Last Closed: 2015-11-19 11:58:30 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2138 normal SHIPPED_LIVE rpm bug fix and enhancement update 2015-11-19 10:39:52 UTC

Description Marek Marusic 2015-02-10 13:53:24 UTC
Present also on RHEL7

Version-Release number of selected component:
4.11.1-25.el7

+++ This bug was initially created as a clone of Bug #1026750 +++

Description of problem:
Parser that generates rpm "Requires:" can generate fake dependencies in case it finds "use something" string in the script. 

Version-Release number of selected component (if applicable):
rpm-4.8.0-32.el6.x86_64

How reproducible:
Always 

Steps to Reproduce:
$ /usr/lib/rpm/perl.req ./mysql_install_db

Actual results:
perl(Data::Dumper)
perl(Fcntl)
perl(File::Basename)
perl(File::Copy)
perl(Getopt::Long)
perl(Sys::Hostname)
perl(hostnames)
perl(strict)


Expected results:
perl(Data::Dumper)
perl(Fcntl)
perl(File::Basename)
perl(File::Copy)
perl(Getopt::Long)
perl(Sys::Hostname)
perl(strict)

Additional info:
$ yum search perl\(hostnames\)Loaded plugins: langpacks, refresh-packagekit
Warning: No matches found for: perl(hostnames)
No matches found


--- Additional comment from Florian Festi on 2014-12-15 07:26:48 EST ---

Patch available upstream

http://rpm.org/gitweb?p=rpm.git;a=commitdiff;h=0d5929ba5eabadec49273bb090ba9158dfccc30c

Comment 2 Florian Festi 2015-06-26 09:43:56 UTC
Patch is included in the rebase

Comment 5 errata-xmlrpc 2015-11-19 11:58:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2138.html


Note You need to log in before you can comment on or make changes to this bug.