Bug 1026760 - git-svn is missing dependencies
git-svn is missing dependencies
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: git (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Wright
Fedora Extras Quality Assurance
:
: 1029185 1037798 1054687 (view as bug list)
Depends On: 1051598
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-05 06:38 EST by Julian Stecklina
Modified: 2014-01-23 06:07 EST (History)
15 users (show)

See Also:
Fixed In Version: git-1.8.5.3-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 06:07:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Stecklina 2013-11-05 06:38:09 EST
Description of problem:
git-svn doesn't work, because it relies on Perl libraries that are not installed.

Version-Release number of selected component (if applicable):
git-svn-1.8.4.2-1.fc20.x86_64

Steps to Reproduce:
1. yum install git-svn
2. git svn clone ...some-svn-repository...
3.

Actual results:
Can't locate Git/SVN.pm in @INC (you may need to install the Git::SVN module) (@INC contains: /usr/share/perl5 /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 .) at /usr/libexec/git-core/git-svn line 25.
BEGIN failed--compilation aborted at /usr/libexec/git-core/git-svn line 25.


Expected results:
git-svn works.
Comment 1 Todd Zullinger 2013-11-05 10:41:41 EST
Thanks for the heads-up. Something appears to be wrong with the perl dependency generation in F20.  Building this same package on older releases works as expected and adds the required perl modules to the rpm requires.

This isn't specific to 1.8.4.2, it occurs with 1.8.3.1 in stable as well:

$ rpmdiff git-svn-1.8.3.1-1.fc19.x86_64.rpm git-svn-1.8.3.1-3.fc20.x86_64.rpm 
removed     REQUIRES /usr/bin/perl  
removed     REQUIRES git = 1.8.3.1-1.fc19
removed     REQUIRES perl >= 0:5.008
removed     REQUIRES perl(Carp)  
removed     REQUIRES perl(Digest::MD5)  
removed     REQUIRES perl(File::Basename)  
removed     REQUIRES perl(File::Find)  
removed     REQUIRES perl(File::Path)  
removed     REQUIRES perl(File::Spec)  
removed     REQUIRES perl(Getopt::Long)  
removed     REQUIRES perl(Git)  
removed     REQUIRES perl(Git::SVN)  
removed     REQUIRES perl(Git::SVN::Editor)  
removed     REQUIRES perl(Git::SVN::Fetcher)  
removed     REQUIRES perl(Git::SVN::Log)  
removed     REQUIRES perl(Git::SVN::Migration)  
removed     REQUIRES perl(Git::SVN::Prompt)  
removed     REQUIRES perl(Git::SVN::Ra)  
removed     REQUIRES perl(Git::SVN::Utils)  
removed     REQUIRES perl(IO::File)  
removed     REQUIRES perl(IPC::Open3)  
removed     REQUIRES perl(Memoize)  
removed     REQUIRES perl(Term::ReadLine)  
removed     REQUIRES perl(lib)  
removed     REQUIRES perl(strict)  
removed     REQUIRES perl(vars)  
removed     REQUIRES perl(warnings)  
added       REQUIRES git = 1.8.3.1-3.fc20
removed     PROVIDES git-svn(x86-64) = 1.8.3.1-1.fc19
added       PROVIDES git-svn(x86-64) = 1.8.3.1-3.fc20
S.5.......T /usr/libexec/git-core/git-remote-testsvn
..........T /usr/libexec/git-core/git-svn
added       /usr/share/doc/git-svn
removed     /usr/share/doc/git-svn-1.8.3.1
removed     /usr/share/doc/git-svn-1.8.3.1/git-svn.html
removed     /usr/share/doc/git-svn-1.8.3.1/git-svn.txt
added       /usr/share/doc/git-svn/git-svn.html
added       /usr/share/doc/git-svn/git-svn.txt
S.5.......T /usr/share/man/man1/git-svn.1.gz

I haven't followed the F20 cycle closely.  Does anyone know if there is some large change to perl that requires changes to all packages that provide or use perl modules?
Comment 2 Todd Zullinger 2013-11-13 17:21:42 EST
*** Bug 1029185 has been marked as a duplicate of this bug. ***
Comment 3 Todd Zullinger 2013-12-04 17:17:17 EST
*** Bug 1037798 has been marked as a duplicate of this bug. ***
Comment 4 Darran Lofthouse 2013-12-19 13:00:54 EST
To get past this error I have manually installed the following two packages: -

  subversion-perl
  perl-Git-SVN
Comment 5 Todd Zullinger 2013-12-21 08:50:59 EST
*** Bug 1045696 has been marked as a duplicate of this bug. ***
Comment 6 Todd Zullinger 2014-01-11 13:26:28 EST
I've finally made some time to look into this issue.  I posted to the packaging list for some help, because it appears that a change in the file package is causing this problem.

https://lists.fedoraproject.org/pipermail/packaging/2014-January/009917.html
Comment 7 Todd Zullinger 2014-01-15 10:28:16 EST
I was pointed to #1051598 by Jan Kaluža on the devel list¹.  He and Panu (rpm maintainer) have been working on this.

¹ https://lists.fedoraproject.org/pipermail/devel/2014-January/193940.html
Comment 8 Todd Zullinger 2014-01-17 10:07:29 EST
*** Bug 1054687 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2014-01-17 11:05:43 EST
git-1.8.5.3-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/git-1.8.5.3-2.fc20
Comment 10 Fedora Update System 2014-01-17 23:23:25 EST
Package git-1.8.5.3-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing git-1.8.5.3-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-1051/git-1.8.5.3-2.fc20
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2014-01-23 06:07:44 EST
git-1.8.5.3-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.