Bug 1027075 - [xfs/xfstests xfs/295] xfs_logprint: unknown log operation type (4e49)
[xfs/xfstests xfs/295] xfs_logprint: unknown log operation type (4e49)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xfsprogs (Show other bugs)
6.5
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Eric Sandeen
Zorro Lang
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-06 00:16 EST by Eryu Guan
Modified: 2017-03-21 07:55 EDT (History)
3 users (show)

See Also:
Fixed In Version: xfsprogs-3.1.1-20.el6
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-21 07:55:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eryu Guan 2013-11-06 00:16:06 EST
Description of problem:
There's a failure reported in bug 1002908, which should be fixed in xfsprogs-3.1.1-14.el6

But I saw a different but similar failure, operation type 4e49(it's 494e in bug 1002908), even tested with xfsprogs-3.1.1-14.el6 (on 1024 block size xfs)

=== xfs/295.out.bad ===
QA output created by 295
xfs_logprint: unknown log operation type (4e49)
Bad data in log

=== full diff out/out.bad ===
--- /dev/fd/63	2013-11-05 04:54:28.922783475 -0500
+++ results/xfs/295.out.bad	2013-11-05 04:54:26.722734005 -0500
@@ -1 +1,3 @@
 QA output created by 295
+xfs_logprint: unknown log operation type (4e49)
+Bad data in log

Full test log
http://beaker-archive.app.eng.bos.redhat.com/beaker-logs/2013/11/5353/535384/1116602/17004872/85744354/test_log-xfs@xfs-295.log

Version-Release number of selected component (if applicable):
xfsprogs-3.1.1-14.el6

How reproducible:
Not sure, I haven't been able to reproduce it manually, just saw once in beaker run. I kept hitting "Not enough headers for data length." issue as described in bug 1002908 comment 5 on my test host.

Steps to Reproduce:
1. check xfs/295 on xfs
2.
3.

Actual results:
xfs_logprint: unknown log operation type (4e49)

Expected results:
test pass

Additional info:
Comment 2 RHEL Product and Program Management 2013-11-10 04:16:30 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Eric Sandeen 2014-02-21 16:07:26 EST
I haven't been able to hit this one manually either, even w/ a 1024-byte block size.
Comment 4 Eric Sandeen 2014-05-05 13:22:21 EDT
Actually devel_ack- for now, seems we can't reproduce this one yet?
Comment 5 RHEL Product and Program Management 2014-05-05 13:46:13 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.
Comment 6 Eryu Guan 2014-05-05 22:43:42 EDT
It was not reproducible. Will retest in rhel6.6 testing phrase and re-open if I can reproduce it again.
Comment 7 Zorro Lang 2016-02-29 22:10:07 EST
Recently I hit this bug when I run xfstests on XFS 1k block size on kernel 621.
4 machines run xfstests on XFS 1k block size, 3 machines hit xfs/295 fail as:
---
QA output created by 295
xfs_logprint: unknown log operation type (4e49)
Bad data in log
---
Comment 8 Zorro Lang 2016-03-03 10:02:25 EST
(In reply to Eryu Guan from comment #6)
> It was not reproducible. Will retest in rhel6.6 testing phrase and re-open
> if I can reproduce it again.

This bug be reproduced on:
---
KERNEL=2.6.32-622.el6.x86_64
XFSPROGS=xfsprogs-3.1.1-19.el6.x86_64
XFSDUMP=xfsdump-3.0.4-4.el6_6.1.x86_64
XFSTESTS=xfstests-20160111-2.git.x86_64
---
when I run xfstests on xfs with 1k block size: https://beaker.engineering.redhat.com/jobs/1249138

This bug was closed due to we can't reproduce it before. But now it can be reproduced several times(nearly 30% rate for now), so I'm going to reopen this bug, for track this problem at least.

Thanks,
Zorro
Comment 9 Eric Sandeen 2016-08-29 15:33:35 EDT
This one gets fixed by 

commit a223e63682bece46eda34fdb9ccb5ec243cd9e2a
Author: Eric Sandeen <sandeen@sandeen.net>
Date:   Mon Mar 3 12:21:49 2014 +1100

    xfs_logprint: Don't error out after split items lose context
Comment 10 Eric Sandeen 2016-08-29 15:34:32 EDT
May as well fix this one along w/ the other xfsprogs fixes for 6.9, it gets us to a cleaner xfstest run and has an upstream patch.
Comment 11 Zorro Lang 2016-08-29 23:07:07 EDT
(In reply to Eric Sandeen from comment #10)
> May as well fix this one along w/ the other xfsprogs fixes for 6.9, it gets
> us to a cleaner xfstest run and has an upstream patch.

Thanks for doing this:)
Comment 16 errata-xmlrpc 2017-03-21 07:55:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0791.html

Note You need to log in before you can comment on or make changes to this bug.