Bug 1027133 - Default rhq-data directory location is incorrect
Default rhq-data directory location is incorrect
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Installer (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity urgent
: ER06
: JON 3.2.0
Assigned To: Stefan Negrea
Mike Foley
:
: 1027245 (view as bug list)
Depends On: 1018213
Blocks: 1012435
  Show dependency treegraph
 
Reported: 2013-11-06 03:51 EST by Filip Brychta
Modified: 2014-01-02 15:39 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Filip Brychta 2013-11-06 03:51:12 EST
Description of problem:
static final String DEFAULT_DATA_DIR = "../../../rhq-data/data";
which is one level above the parent directory of rhq-server.

We have following directory structure:
/home/hudson/rhq-server-4.10.0-SNAPSHOT

so when running ./rhqctl install it tries to install rhq-data to /home which fails because of write permissions
             
Version:
rhq-server-4.10.0-SNAPSHOT
d3ea23b

See commit 85aa4b31
Comment 1 Heiko W. Rupp 2013-11-06 04:04:55 EST
This is on purpose, as this way you can install a new version of the rhq-server next to the existing one, that uses the same data dir and then wipe the old server directory.
If the data directory of the storage node would be inside the rhq-server, you could loose it that way or you would have to manually move it around.

Solution: don't install the server into /home/hudson, but /home/hudson/rhq
Comment 2 John Sanda 2013-11-06 10:26:25 EST
The default location is the same. The change for the default location was made in bug 1002226. The only change is to use relative paths, and the reason for doing so is explained in comment 1.
Comment 3 John Sanda 2013-11-06 10:34:12 EST
Correction from comment 2. The default location *should be* the same. The changes I made for bug 1018213 moved the default directory one level up. I will go ahead and fix this.
Comment 4 Filip Brychta 2013-11-07 02:51:37 EST
*** Bug 1027245 has been marked as a duplicate of this bug. ***
Comment 5 Stefan Negrea 2013-11-08 10:39:19 EST
This issue has been fixed as part of bug 1018213, the check permissions method was checking the wrong directory for write permissions.

release/jon3.2.x branch commit:

https://git.fedorahosted.org/cgit/rhq/rhq.git/commit/?h=release/jon3.2.x&id=6e09ef87a476b15c7853a7f7837374ddab7344b7



Please retest.
Comment 6 Simeon Pinder 2013-11-19 10:48:46 EST
Moving to ON_QA as available for testing with new brew build.
Comment 7 Filip Brychta 2013-11-19 11:34:59 EST
Verified on
Version :	
3.2.0.ER6
Build Number :	
f7dcd50:643508a

Note You need to log in before you can comment on or make changes to this bug.