Bug 1027160 - Kickstarts don't work on Live
Kickstarts don't work on Live
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
RejectedBlocker
:
: 1026825 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-06 05:01 EST by Kamil Páral
Modified: 2014-12-15 14:18 EST (History)
9 users (show)

See Also:
Fixed In Version: anaconda-21.15-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-04 13:25:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda screen after running Live with kickstart (51.35 KB, image/png)
2013-11-06 05:01 EST, Kamil Páral
no flags Details
default.ks (537 bytes, text/plain)
2013-11-06 05:03 EST, Kamil Páral
no flags Details
anaconda.log (17.21 KB, text/plain)
2013-11-06 05:03 EST, Kamil Páral
no flags Details
program.log (44.95 KB, text/plain)
2013-11-06 05:03 EST, Kamil Páral
no flags Details
storage.log (275.81 KB, text/plain)
2013-11-06 05:03 EST, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2013-11-06 05:01:46 EST
Created attachment 820268 [details]
anaconda screen after running Live with kickstart

Description of problem:
When I try to use kickstart on Live media, anaconda doesn't download the file and it flushes all default settings.

I tried using inst.ks= at boot, and also liveinst --ks file and liveinst --kickstart=file. Everything behaves the same. The file is _not_ downloaded (I see no access on my web server).

Anaconda skips the language selection screen and shows errors at most of the dialogs, indicating that no defaults were used.

Please note that netinst + kickstart works fine, so this problem is only related to Lives.

Version-Release number of selected component (if applicable):
anaconda 20.25.6

How reproducible:
always

Steps to Reproduce:
1. try to run anaconda with a kickstart from Live by any means possible
2. see that the file was not downloaded
3. see that anaconda acts as having no defaults at all
Comment 1 Kamil Páral 2013-11-06 05:03:21 EST
Created attachment 820269 [details]
default.ks
Comment 2 Kamil Páral 2013-11-06 05:03:27 EST
Created attachment 820270 [details]
anaconda.log
Comment 3 Kamil Páral 2013-11-06 05:03:34 EST
Created attachment 820271 [details]
program.log
Comment 4 Kamil Páral 2013-11-06 05:03:41 EST
Created attachment 820272 [details]
storage.log
Comment 5 Kamil Páral 2013-11-06 05:04:41 EST
*** Bug 1026825 has been marked as a duplicate of this bug. ***
Comment 6 Kamil Páral 2013-11-06 05:10:36 EST
We have this criteria:
"The installer must be able to complete a scripted installation which duplicates the default interactive installation as closely as possible. "
https://fedoraproject.org/wiki/Fedora_20_Beta_Release_Criteria#Scripted_installation

However, it can be argued that netinst/dvd+kickstart work fine as a workaround, therefore this is not as critical as it could be.
Comment 7 Jaroslav Reznik 2013-11-06 10:15:16 EST
As it works for netinst/dvd+kickstart, live anaconda could be updated later (as part of documented workaround).
Comment 8 Mike Ruckman 2013-11-06 12:13:19 EST
Discussed in 2013-11-06 Blocker Review Meeting [1]. Voted a RejectedBlocker because Kickstarts aren't supposed to work with livecd. Kickstarts work fine with pxe and netinst.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-11-06/
Comment 9 Zeeshan Ali 2014-12-15 14:18:19 EST
Express instalation of Fedora is one the most attractive features of gnome-boxes and Fedora deciding to ditch the installation DVDs w/o adding support for kickstart in live breaks this completely for gnome-boxes. :(

Note You need to log in before you can comment on or make changes to this bug.