Bug 102718 - xemacs w/o i18n
xemacs w/o i18n
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xemacs (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-20 05:24 EDT by Stig Hackvan
Modified: 2015-01-07 19:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-07 03:12:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stig Hackvan 2003-08-20 05:24:39 EDT
it would be very nice to have xemacs w/o i18n available as a parallel package in
the standard redhat distribution (rather like emacs was once available as both
emacs and emacs-nox so it could be installed w/o X11 libs)

-- stig
Comment 1 Jens Petersen 2003-09-02 02:51:39 EDT
Hi Stig,

Hmmm, I see and can you give some motivation for this, please?
Comment 2 Stig Hackvan 2003-10-04 03:39:36 EDT
Sure: basic motivation is roughly the same as the once-upon-a-time motivation
for packaging two versions of emacs (with and without X11)...

xemacs is an interesting alternative to gnu emacs for reasons other than MULE
support, but the requirement that various canna servers and japanese input
method libraries be installed along with xemacs diminish the appeal of redhat's
xemacs package for non-japanese/chinese users...

-- stig
Comment 3 Jens Petersen 2003-10-06 01:57:10 EDT
Actually no IM servers need to be installed for xemacs.
The dependency on Canna is an error, it should depend on
Canna-libs instead.

Canna-libs and FreeWnn-libs aren't that big, but it might
not be such a big deal to build without them enabled.
After all Emacs doesn't support XIM directly either.
On the other hand compiling with Mule support I think
would be totally unacceptable, which I thought was maybe
what you were suggesting in your original report.
Comment 4 Stig Hackvan 2003-10-06 03:11:26 EDT
I seem to recall that either wnn or canna -libs "require" the base package,
which is (i also vaguely recall) set to automatically run @ boot by default... 
it's been a while since i tried installing from boot, but that's what i
remember...  a bunch of stuff i didn't want.

thanks for your friendliness towards a build w/o the dependencies (mayhaps even
a .src.rpm supporting --without mule)...  this could be roughly equivalent to
removing (approximately) this list of sources from the .src.rpm and the
associated build-time dependencies.

xemacs-mule-sumo-2003-02-05.tar.bz2
Emacs.ad.Big5
Emacs.ad.GB2312
Emacs.ad.Japanese
Emacs.ad.Korean
auctex-texjp-platex.patch
auctex-texsite-jlatex-detect-69129.patch
egg-wnn-host-unix-79826.patch

--stig
Comment 5 Stig Hackvan 2003-10-06 03:12:56 EDT
err, change "installed from boot" to "installed via anaconda"
Comment 6 Jens Petersen 2003-10-07 07:34:57 EDT
Well Canna-libs doesn't seem to require Canna, and nor
does FreeWnn-libs require FreeWnn currently afaict.

I could probably be persuaded to add "--without mule" as
an srpm build option, though I don't expect xemacs without
mule to go into Fedora Core (perhaps someone will do it for
Fedora Alternatives?).
Comment 7 Jens Petersen 2003-11-05 20:34:01 EST
What locale do you normally run xemacs in btw?

If it is with utf-8 encoding, and you want utf-8 support
in xemacs, then you actually need MuleUCS and mule support
in order to use it.
Comment 8 Jens Petersen 2003-11-07 03:12:17 EST
21.4.14-5 has a "--without mule" rpmbuild options defined now,
which in addition to disabling mule support also turns off
native IM support.

Note You need to log in before you can comment on or make changes to this bug.