Bug 102723 - freedb entries must be iso-8859-1
freedb entries must be iso-8859-1
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: grip (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
http://www.freedb.org/modules.php?nam...
: FutureFeature
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-08-20 06:59 EDT by Alexandre Oliva
Modified: 2014-03-16 22:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 18:09:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2003-08-20 06:59:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
According to the freedb FAQ, entries must be submitted in ISO-8859-1 format, not
in UTF-8, which we use by default.  The wire protocol goes both ways: if I
retrive entries with non-ASCII characters with grip running in a UTF-8 locale,
it gets very confused.  It should convert entries downloaded in iso-8859-1 to
the locale representation, and convert back to iso-8859-1 when submitting new
entries.

Version-Release number of selected component (if applicable):
grip-3.0.7-3

How reproducible:
Always

Steps to Reproduce:
1.Start grip in a UTF-8 locale
2.Attempt to register a CD with a non-ASCII character in its title
3.Do it again in a iso-8859-1 locale.
4.Restart grip in a UTF-8 locale.
5.Retrieve the entry

Actual Results:  For 2, You get an e-mail back stating that an invalid character
set was used.  For 5, you get back a mangled entry.

Expected Results:  The e-mail contents should be generated in iso-8859-1, and
downloaded entries should be converted back from iso-8859-1 to the chosen
locale.  The wire protocol specifies iso-8859-1.

Additional info:

Unfortunately, choosing a non-UTF8 locale means you have to drop non-ASCII
characters from filenames, which often makes song titles unreadable.
Comment 1 Bill Nottingham 2003-08-20 14:55:58 EDT
I'm probably not going to get to this very soon. Feel free to file upstream at:
http://sourceforge.net/tracker/?atid=103714&group_id=3714&func=browse

:)
Comment 3 Alexandre Oliva 2003-10-13 11:17:52 EDT
https://sourceforge.net/tracker/?func=detail&atid=103714&aid=792148&group_id=3714
was reportedly fixed on Oct 1, but AFAICT there isn't any newer stable release
containing hte patch.  I haven't looked at the patch to see whether it would be
easy to back-port, but it pobably isn't worth doing anyway.
Comment 4 Bill Nottingham 2005-02-04 18:09:24 EST
grip is no longer shipped in the development tree; as such, it is unlikely older
bugs will be fixed.
Comment 5 Alexandre Oliva 2005-02-05 11:02:09 EST
I thought it was being pushed to extras, not simply dropped.  Anyhow,
I believe the problem is fixed in FC3.

Note You need to log in before you can comment on or make changes to this bug.