Bug 1027409 - [RHS][RFE] RFE for NFS connection behavior, change volume
[RHS][RFE] RFE for NFS connection behavior, change volume
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
mainline
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: santosh pradhan
:
: GLUSTER-3725 (view as bug list)
Depends On: 929036
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-06 13:47 EST by santosh pradhan
Modified: 2014-09-30 11:27 EDT (History)
11 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 929036
Environment:
Last Closed: 2014-04-17 07:50:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-11-06 13:52:43 EST
REVIEW: http://review.gluster.org/6236 (gNFS: RFE for NFS connection behavior) posted (#1) for review on master by Santosh Pradhan (spradhan@redhat.com)
Comment 2 Anand Avati 2013-11-07 04:28:53 EST
REVIEW: http://review.gluster.org/6236 (gNFS: RFE for NFS connection behavior) posted (#2) for review on master by Santosh Pradhan (spradhan@redhat.com)
Comment 3 Anand Avati 2013-11-09 11:35:52 EST
REVIEW: http://review.gluster.org/6236 (gNFS: RFE for NFS connection behavior) posted (#3) for review on master by Santosh Pradhan (spradhan@redhat.com)
Comment 4 Anand Avati 2013-11-11 11:18:19 EST
REVIEW: http://review.gluster.org/6236 (gNFS: RFE for NFS connection behavior) posted (#4) for review on master by Santosh Pradhan (spradhan@redhat.com)
Comment 5 Anand Avati 2013-11-14 06:48:48 EST
REVIEW: http://review.gluster.org/6236 (gNFS: RFE for NFS connection behavior) posted (#5) for review on master by Santosh Pradhan (spradhan@redhat.com)
Comment 6 Anand Avati 2013-11-14 07:00:51 EST
REVIEW: http://review.gluster.org/6236 (gNFS: RFE for NFS connection behavior) posted (#6) for review on master by Santosh Pradhan (spradhan@redhat.com)
Comment 7 santosh pradhan 2013-11-25 00:20:01 EST

commit e479660d9dd8bf7017c7dc78ccfa6edd9c51ec7a
Author: Santosh Kumar Pradhan <spradhan@redhat.com>
Date:   Mon Oct 28 12:46:37 2013 +0530

    gNFS: RFE for NFS connection behavior
    
    Implement reconfigure() for NFS xlator so that volume set/reset wont
    restart the NFS server process. But few options can not be reconfigured
    dynamically e.g. nfs.mem-factor, nfs.port etc which needs NFS to be
    restarted.
    
    Change-Id: Ic586fd55b7933c0a3175708d8c41ed0475d74a1c
    BUG: 1027409
    Signed-off-by: Santosh Kumar Pradhan <spradhan@redhat.com>
    Reviewed-on: http://review.gluster.org/6236
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 8 Niels de Vos 2014-04-17 07:50:22 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 9 Niels de Vos 2014-09-30 11:27:51 EDT
*** Bug 765457 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.