Bug 765457 - (GLUSTER-3725) [FEAT] Avoid nfs server restarts when there is change in config file
[FEAT] Avoid nfs server restarts when there is change in config file
Status: CLOSED DUPLICATE of bug 1027409
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
mainline
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: GlusterFS Bugs list
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-17 03:17 EDT by Krishna Srinivas
Modified: 2014-09-30 11:27 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-30 11:27:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krishna Srinivas 2011-10-17 03:17:37 EDT
From gluster-users list:

not 'exportfs -f' but 'exportfs -r'. sorry.
- Hide quoted text -


(2011/10/14 18:17), Tomoaki Sato wrote:
Krishna,

Thank you for your comments.
I've changed the script not to repeat gluster volume set command with same arguments.
Do you have any plans to make gluster restart-free like 'exportfs -f' of nfs.

tomo sato

(2011/10/14 18:03), Krishna Srinivas wrote:
Hi Tomo Sato,

Using gluster volume set command will restart the nfs server, hence
you should change the script so that it does not restart the nfs
server too often.

You can consult with the person who installed the script as it is not
a part of gluster installed scripts.

Krishna
Comment 1 kaushik 2011-10-17 04:29:37 EDT
*** Bug 2264 has been marked as a duplicate of this bug. ***
Comment 2 Niels de Vos 2014-09-30 11:27:51 EDT

*** This bug has been marked as a duplicate of bug 1027409 ***

Note You need to log in before you can comment on or make changes to this bug.