Bug 102746 - Logwatch not restricting up2date log range to yesterday
Logwatch not restricting up2date log range to yesterday
Status: CLOSED DUPLICATE of bug 99438
Product: Red Hat Linux
Classification: Retired
Component: logwatch (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-20 11:58 EDT by Matthew Prentice
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Prentice 2003-08-20 11:58:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
In the daily logwatch email all sections are restricted to yesterday, as per 
the config file, except for up2date.  The up2date section lists all entries.

We have recently installed 3 RH9 servers each running logwatch.  All three 
emails list all up2date entries in the log file since logrotate last ran.  One 
server is still showing the up2date entries for Aug 1, the day we installed.

I've noticed the date format is different in the up2date log verses the other 
log files and wonder if this is the cause.

up2date format:
[Mon Aug 18 11:02:14 2003] up2date installing packages: ['unzip-5.50-33']

other logs format:
Aug 18 08:16:05 ext1 su(pam_unix)[12161]: session closed for user root

MRP
---

Version-Release number of selected component (if applicable):
logwatch-4.3.1-2

How reproducible:
Always

Steps to Reproduce:
1. ensure logwatch is configured to range=yesterday (archives=yes is optional)
2. use up2date to install some packages
3. watch the logwatch entries for up2date for the next few days

Actual Results:  The up2date entries for days prior to yesterday continue to 
show up.

Expected Results:  The up2date entries should be restricted only to yesterday.

Additional info:
Comment 1 Elliot Lee 2003-08-21 07:56:36 EDT

*** This bug has been marked as a duplicate of 99438 ***
Comment 2 Matthew Prentice 2003-08-21 08:16:08 EDT
I agree this is similar to 99438.  However,  in this case the Yesterday range 
is working correctly for all logs except for up2date.  It appears in 99438 that 
the Yesterday range is not working for any of the logs.
Comment 3 Red Hat Bugzilla 2006-02-21 13:58:10 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.