This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 99438 - logwatch appears to ignore 'Yesterday' range
logwatch appears to ignore 'Yesterday' range
Status: CLOSED DUPLICATE of bug 80496
Product: Red Hat Linux
Classification: Retired
Component: logwatch (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
: 102746 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-19 12:15 EDT by Cott Lang
Modified: 2007-04-18 12:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:57:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Cott Lang 2003-07-19 12:15:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

Description of problem:
Every day logwatch mails me a week or so's worth of logs. I'm using the default
logwatch.conf, and it has Range = yesterday.  Maybe I'm wrong, but it would
appear that this should make logwatch only mail yesterday's entries out every
day, but I quite clearly get everything in the log directory. :)



Version-Release number of selected component (if applicable):
logwatch-4.3.1-2

How reproducible:
Always

Steps to Reproduce:
1. Allow log entries to pile up
2. Let logwatch run
3. Read your email
    

Actual Results:  One day's worth of entries mailed

Expected Results:  Everything is mailed

Additional info:
Comment 1 Elliot Lee 2003-08-21 07:56:38 EDT
*** Bug 102746 has been marked as a duplicate of this bug. ***
Comment 2 Cott Lang 2003-08-21 08:54:27 EDT
Upon further investigation, bug id 102746 is correct, I believe this is limited
to up2date logs. There have been so many lately. :)
Comment 3 Damian Menscher 2003-08-21 13:45:41 EDT
In case you didn't already figure it out, it's because several of the conf files
in /etc/log.d/conf/logfiles are missing the line:

*ApplyStdDate

up2date.conf isn't the only one affected....
Comment 4 Matthew Prentice 2003-08-21 15:06:33 EDT
Thank you.  I put that entry in the file and re-ran the report successfully.
Comment 5 Cott Lang 2003-08-24 11:33:37 EDT
Thanks ...


Redhat - is there any hope for a fix on this from you guys?  I really hate to go
edit a couple dozen machines... but I guess I can.
Comment 6 Gilles Detillieux 2003-10-30 11:32:31 EST
Actually, the real problem is the missing scripts in the
/etc/log.d/scripts/logfiles/{autorpm,cron,up2date} directories.

See bug 80496 for the solution.  I guess 99438 should be marked as duplicate.
Comment 7 Elliot Lee 2004-08-20 14:53:16 EDT

*** This bug has been marked as a duplicate of 80496 ***
Comment 8 Red Hat Bugzilla 2006-02-21 13:57:07 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.