Bug 1027460 - Add gluster puppet module to the packstack-modules-puppet package
Add gluster puppet module to the packstack-modules-puppet package
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
4.0
Unspecified Unspecified
high Severity medium
: rc
: 4.0
Assigned To: Martin Magr
Nir Magnezi
: OtherQA, Triaged
Depends On:
Blocks: 1027463
  Show dependency treegraph
 
Reported: 2013-11-06 16:54 EST by Crag Wolfe
Modified: 2016-04-26 10:29 EDT (History)
7 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.14.dev919.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1027463 (view as bug list)
Environment:
Last Closed: 2013-12-19 19:34:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 60201 None None None Never

  None (edit)
Description Crag Wolfe 2013-11-06 16:54:15 EST
Description of problem:

Add the contents of the gluster module, https://github.com/redhat-openstack/puppet-openstack-storage , under /usr/share/openstack-puppet/modules/gluster in the openstack-puppet-modules rpm.

This is needed for gluster client/server configuration in puppet manifests.
Comment 2 Alvaro Lopez Ortega 2013-12-04 12:06:37 EST
We are adding the module to the package.
Comment 3 Scott Lewis 2013-12-09 10:33:42 EST
Adding OtherQA for bugs in MODIFIED
Comment 6 Lon Hohberger 2013-12-11 15:07:20 EST
With packstack-modules-puppet from:
   openstack-packstack-2013.1.1-0.37.dev705.el6ost.noarch

[root@localhost ~]# rpm -ql packstack-modules-puppet | grep gluster
/usr/share/packstack/modules/cinder/manifests/volume/glusterfs.pp

With packstack-modules-puppet from:
   openstack-packstack-2013.1.1-0.37.dev705.el6ost.noarch

[root@localhost ~]# rpm -ql packstack-modules-puppet | grep gluster
/usr/share/packstack/modules/cinder/manifests/volume/glusterfs.pp
/usr/share/packstack/modules/gluster
/usr/share/packstack/modules/gluster/README.md
/usr/share/packstack/modules/gluster/example-storage.pp
/usr/share/packstack/modules/gluster/lib
/usr/share/packstack/modules/gluster/lib/puppet
/usr/share/packstack/modules/gluster/lib/puppet/provider
/usr/share/packstack/modules/gluster/lib/puppet/provider/volume
/usr/share/packstack/modules/gluster/lib/puppet/provider/volume/gluster.rb
/usr/share/packstack/modules/gluster/lib/puppet/type
/usr/share/packstack/modules/gluster/lib/puppet/type/volume.rb
/usr/share/packstack/modules/gluster/manifests
/usr/share/packstack/modules/gluster/manifests/client.pp
/usr/share/packstack/modules/gluster/manifests/init.pp
/usr/share/packstack/modules/gluster/manifests/params.pp
/usr/share/packstack/modules/gluster/manifests/server.pp
Comment 8 errata-xmlrpc 2013-12-19 19:34:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.