Bug 1027682 - DeviceError: ('Cannot destroy non-leaf device', 'fedora_dhcp-29-193-root')
DeviceError: ('Cannot destroy non-leaf device', 'fedora_dhcp-29-193-root')
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
20
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:fc56e149e3b61118352b91e9ea3...
: CommonBugs
: 995892 (view as bug list)
Depends On:
Blocks: F20FinalBlocker 1029634
  Show dependency treegraph
 
Reported: 2013-11-07 04:36 EST by Kamil Páral
Modified: 2014-12-10 10:55 EST (History)
13 users (show)

See Also:
Fixed In Version: pykickstart-1.99.46-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1029634 (view as bug list)
Environment:
Last Closed: 2013-11-23 22:59:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (1.25 MB, text/plain)
2013-11-07 04:36 EST, Kamil Páral
no flags Details
File: anaconda.log (57.98 KB, text/plain)
2013-11-07 04:36 EST, Kamil Páral
no flags Details
File: environ (405 bytes, text/plain)
2013-11-07 04:36 EST, Kamil Páral
no flags Details
File: lsblk_output (2.26 KB, text/plain)
2013-11-07 04:36 EST, Kamil Páral
no flags Details
File: nmcli_dev_list (8.84 KB, text/plain)
2013-11-07 04:36 EST, Kamil Páral
no flags Details
File: os_info (291 bytes, text/plain)
2013-11-07 04:36 EST, Kamil Páral
no flags Details
File: program.log (51.80 KB, text/plain)
2013-11-07 04:36 EST, Kamil Páral
no flags Details
File: storage.log (160.25 KB, text/plain)
2013-11-07 04:37 EST, Kamil Páral
no flags Details
File: syslog (98.71 KB, text/plain)
2013-11-07 04:37 EST, Kamil Páral
no flags Details
File: ifcfg.log (557 bytes, text/plain)
2013-11-07 04:37 EST, Kamil Páral
no flags Details
File: packaging.log (883.92 KB, text/plain)
2013-11-07 04:37 EST, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2013-11-07 04:36:13 EST
Description of problem:
I went to custom partitioning, there was a previously installed encrypted F20 installation. I unlocked it. Then I re-used old swap and /boot partition in the new layout. I deleted old /home partition and reused old / partition. The / partition was marked as reformat and also enlarge from 50 to 60 GB (I had free space because I deleted /home). Anaconda crashed during the first stage of installation.

Version-Release number of selected component:
anaconda-20.25.6-1

The following was filed automatically by anaconda:
anaconda 20.25.6-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 810, in _preDestroy
    raise DeviceError("Cannot destroy non-leaf device", self.name)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2715, in _preDestroy
    StorageDevice._preDestroy(self)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2734, in resize
    self._preDestroy()
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 403, in execute
    self.device.resize()
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 310, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 169, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib/python2.7/site-packages/pyanaconda/install.py", line 142, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
DeviceError: ('Cannot destroy non-leaf device', 'fedora_dhcp-29-193-root')

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   inst.stage2=http://download.eng.brq.redhat.com/pub/fedora/fedora-alt/stage/20-Beta-RC5/Fedora/i386/os/ inst.repo=http://download.eng.brq.redhat.com/pub/fedora/linux/development/20/i386/os/ initrd=F20/Beta-RC5/i386/initrd.img BOOT_IMAGE=F20/Beta-RC5/i386/vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.6-301.fc20.i686
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Beta

Potential duplicate: bug 995892
Comment 1 Kamil Páral 2013-11-07 04:36:27 EST
Created attachment 820956 [details]
File: anaconda-tb
Comment 2 Kamil Páral 2013-11-07 04:36:33 EST
Created attachment 820957 [details]
File: anaconda.log
Comment 3 Kamil Páral 2013-11-07 04:36:37 EST
Created attachment 820958 [details]
File: environ
Comment 4 Kamil Páral 2013-11-07 04:36:42 EST
Created attachment 820959 [details]
File: lsblk_output
Comment 5 Kamil Páral 2013-11-07 04:36:46 EST
Created attachment 820960 [details]
File: nmcli_dev_list
Comment 6 Kamil Páral 2013-11-07 04:36:53 EST
Created attachment 820961 [details]
File: os_info
Comment 7 Kamil Páral 2013-11-07 04:36:57 EST
Created attachment 820962 [details]
File: program.log
Comment 8 Kamil Páral 2013-11-07 04:37:01 EST
Created attachment 820963 [details]
File: storage.log
Comment 9 Kamil Páral 2013-11-07 04:37:06 EST
Created attachment 820964 [details]
File: syslog
Comment 10 Kamil Páral 2013-11-07 04:37:10 EST
Created attachment 820965 [details]
File: ifcfg.log
Comment 11 Kamil Páral 2013-11-07 04:37:18 EST
Created attachment 820966 [details]
File: packaging.log
Comment 12 Kamil Páral 2013-11-07 04:37:59 EST
Correction: The / partition was marked as reformat, *encrypted* and also enlarge from 50 to 60 GB (I had free space because I deleted /home).
Comment 13 Kamil Páral 2013-11-07 04:40:21 EST
I guess this violates our Beta criteria:
https://fedoraproject.org/wiki/Fedora_20_Beta_Release_Criteria#Custom_partitioning
Comment 14 Adam Williamson 2013-11-07 05:42:58 EST
that...seems like a pretty complex reproducer. can you nail down more precisely the problematic bit?
Comment 15 Martin Krizek 2013-11-07 06:11:07 EST
Reproduced 1027682

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.6-301.fc20.x86_64
package:        anaconda-20.25.6-1
product:        Fedora
reason:         DeviceError: ('Cannot destroy non-leaf device', 'fedora-root')
release:        Cannot get release name.
version:        20-Beta
Comment 16 Kamil Páral 2013-11-07 08:27:39 EST
A simpler reproducer:

1. Install a default Fedora LVM install - /boot as standard partition, swap and / as LVM.
2. Reboot into installer again.
3. Go into custom part and reuse /boot and swap.
4. Click on /, click Reformat, click Encrypt and also resize it (I used 6 GB instead of original 8 GB). Click Apply.
5. See that the size was _not_ updated (that's probably related to bug 1027714).
6. Continue with install. See crash during installation start.

I believe the root cause of this bug is exactly the same as in bug 1026466 comment 9. It's caused by the resize attempt. The size is not updated in Anaconda GUI, but it tries to perform the operation (probably with some invalid arguments) and it fails.
Comment 17 Mike Ruckman 2013-11-07 12:51:05 EST
Discussed in the 2013-11-07 Go/No-Go meeting [1]. Voted as a RejectedBlocker as resize issues are generally considered for blocking final release, not beta. As such, this bug is rejected as a release blocking issue for F20 beta but please re-propose as a Final Blocker and mark for inclusion in CommonBugs.

[1] http://meetbot.fedoraproject.org/meetbot/meetbot/fedora-meeting-2/2013-11-07/
Comment 18 Adam Williamson 2013-11-13 14:45:23 EST
Discussed at 2013-11-13 blocker review meeting - http://meetbot.fedoraproject.org/fedora-blocker-review/2013-11-13/f20-final-blocker-review-1.2013-11-13-17.01.log.txt . Accepted as a blocker per criterion "Reject or disallow invalid disk and volume configurations without crashing." (custom partitioning)
Comment 19 Adam Williamson 2013-11-13 14:46:10 EST
or possibly "Any installer mechanism for resizing storage volumes must correctly attempt the requested operation."
Comment 20 Fedora Update System 2013-11-15 21:18:25 EST
anaconda-20.25.8-1.fc20, pykickstart-1.99.46-1.fc20, python-blivet-0.23.5-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/pykickstart-1.99.46-1.fc20,python-blivet-0.23.5-1.fc20,anaconda-20.25.8-1.fc20
Comment 21 Fedora Update System 2013-11-17 02:03:30 EST
Package anaconda-20.25.8-1.fc20, pykickstart-1.99.46-1.fc20, python-blivet-0.23.5-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-20.25.8-1.fc20 pykickstart-1.99.46-1.fc20 python-blivet-0.23.5-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21553/pykickstart-1.99.46-1.fc20,python-blivet-0.23.5-1.fc20,anaconda-20.25.8-1.fc20
then log in and leave karma (feedback).
Comment 22 Adam Williamson 2013-11-20 14:58:55 EST
Status reviewed at 2013-11-20 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-11-20/f20-blocker-review.2013-11-20-17.00.log.txt . This bug should be fixed in TC2, and needs confirmation from QA.
Comment 23 Kamil Páral 2013-11-21 05:54:28 EST
Verified fixed with F20 TC2.
Comment 24 Fedora Update System 2013-11-23 22:59:06 EST
pykickstart-1.99.46-1.fc20, python-blivet-0.23.5-1.fc20, anaconda-20.25.9-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 25 David Shea 2014-12-10 10:55:07 EST
*** Bug 995892 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.