Bug 1026466 - blivet shows existing LVs as not taking up any space in the VG
blivet shows existing LVs as not taking up any space in the VG
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
20
All Linux
unspecified Severity high
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 1025911 (view as bug list)
Depends On:
Blocks: F20BetaBlocker F20FinalBlocker 1026468
  Show dependency treegraph
 
Reported: 2013-11-04 12:46 EST by David Lehman
Modified: 2013-11-08 23:25 EST (History)
10 users (show)

See Also:
Fixed In Version: python-blivet-0.23.4-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1026468 (view as bug list)
Environment:
Last Closed: 2013-11-08 23:25:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda-tb 20.25.6 related to comment 9 (619.10 KB, text/plain)
2013-11-07 08:09 EST, Kamil Páral
no flags Details

  None (edit)
Description David Lehman 2013-11-04 12:46:47 EST
Description of problem:
Existing LVM configurations detected by blivet show existing VGs as having their full capacity available in spite of any existing LVs. This is due to a regression introduced when fixing bug 1013800.

Version-Release number of selected component (if applicable):
python-blivet-0.23.3-1

How reproducible:
Always

Steps to Reproduce:
1. create an anaconda automatic partitioning layout (write it to disk)
2. reboot into the installer using the same disk(s)
3. in the custom storage spoke, create a new LV

Actual results:
A new LV will be added with up to the full size of the VG even though the VG is already full.

Expected results:
Creation of a new LV should fail due to the disk(s) and VG being full.

Additional info:
Comment 1 David Lehman 2013-11-04 12:47:41 EST
I have a patch for this and have verified that it fixes this problem.
Comment 2 Jan Sedlák 2013-11-06 05:22:59 EST
When someone tries to continue with installation, anaconda crashes with "DeviceCreateError: ('lvcreate failed for fedora/root00: running lvm lvcreate -L 15496m -n root00 fedora failed', 'fedora-root00')". It shows as bug 1021507 in ABRT. I will not mark bug 1021507 as duplicate, because it seems that it is different bug.
Comment 3 David Lehman 2013-11-06 09:39:37 EST
*** Bug 1025911 has been marked as a duplicate of this bug. ***
Comment 4 Mike Ruckman 2013-11-06 12:53:37 EST
Discussed in 2013-11-06 Blocker Review Meeting [1]. Voted an AcceptedBlocker. This bug lets user to set a layout which cannot be created. Also it violates criterion: "When using the custom partitioning flow, the installer must be able to: Correctly interpret, and modify as described below, any disk with a valid ms-dos or gpt disk label and partition table containing ext4 partitions, LVM and/or btrfs volumes, and/or software RAID arrays at RAID levels 0, 1 and 5 containing partitions." [2]

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-11-06/
[2] https://fedoraproject.org/wiki/Fedora_20_Beta_Release_Criteria#Custom_partitioning
Comment 5 Fedora Update System 2013-11-06 14:02:04 EST
python-blivet-0.23.4-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/python-blivet-0.23.4-1.fc20
Comment 6 Adam Williamson 2013-11-06 15:17:39 EST
If I understand the description correctly, verified the fix in pre-RC5 smoke testing of 0.23.4.
Comment 7 Kamil Páral 2013-11-07 04:42:20 EST
When I tried to verify this bug I've hit bug 1027682.
Comment 8 Kamil Páral 2013-11-07 06:07:56 EST
With a much simpler test case this works correctly, therefore verified.
Comment 9 Kamil Páral 2013-11-07 08:03:55 EST
I tried to reproduce bug 1027682 or bug 1008732. I might have found yet another bug.

Reproducer:
1. Install a default Fedora LVM install - /boot as standard partition, swap and / as LVM.
2. Reboot into installer again.
3. Go into custom part and reuse /boot and swap.
4. Click on /, click Reformat and also resize it (I used 6 GB instead of original 8 GB). Click Apply.
5. See that the size was _not_ updated (that's probably related to bug 1027714).
6. Continue with install. See crash during installation start.

Please note that when I performed the same steps as above, but without the attempt to resize /, everything worked well.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.6-301.fc20.x86_64
package:        anaconda-20.25.6-1
product:        Fedora
reason:         LVMError: lvresize failed for root: running lvm lvresize --force -L 8712m fedora/root failed
release:        Cannot get release name.
version:        20-Beta
Comment 10 Kamil Páral 2013-11-07 08:09:12 EST
Created attachment 821098 [details]
anaconda-tb 20.25.6 related to comment 9
Comment 11 Kamil Páral 2013-11-07 08:10:58 EST
In comment 9 ABRT found that crash to be a duplicate of bug 1025911 which is a duplicate of this bug. So, unless it was matched by a mistake, this is not fixed. Reopening.
Comment 12 Kamil Páral 2013-11-07 08:22:31 EST
I have reproduced comment 9 by following the exactly same steps. Seems to happen reliably.
Comment 13 David Lehman 2013-11-07 11:35:14 EST
The issue reported in comment 9 is not the same as the problem reported initially in this bug. Please open a separate report with the logs and update the status of this bug as appropriate. Thanks.
Comment 14 Kamil Páral 2013-11-07 11:48:50 EST
(In reply to David Lehman from comment #13)
> The issue reported in comment 9 is not the same as the problem reported
> initially in this bug. Please open a separate report with the logs and
> update the status of this bug as appropriate. Thanks.

OK. Reported as a separate bug 1028110.
Comment 15 Fedora Update System 2013-11-08 23:25:13 EST
python-blivet-0.23.4-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.