This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1027846 - PartitionException: Partition is not part of the disk it is being removed from
PartitionException: Partition is not part of the disk it is being removed from
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
20
All Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:a307e4d5f492c5748e9fcde04f5...
:
Depends On:
Blocks: F20FinalBlocker 1029628
  Show dependency treegraph
 
Reported: 2013-11-07 08:02 EST by Lukas Brabec
Modified: 2013-11-23 22:59 EST (History)
12 users (show)

See Also:
Fixed In Version: pykickstart-1.99.46-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1029628 (view as bug list)
Environment:
Last Closed: 2013-11-23 22:59:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (821.91 KB, text/plain)
2013-11-07 08:02 EST, Lukas Brabec
no flags Details
File: anaconda.log (48.25 KB, text/plain)
2013-11-07 08:02 EST, Lukas Brabec
no flags Details
File: environ (404 bytes, text/plain)
2013-11-07 08:02 EST, Lukas Brabec
no flags Details
File: lsblk_output (1.48 KB, text/plain)
2013-11-07 08:02 EST, Lukas Brabec
no flags Details
File: nmcli_dev_list (4.27 KB, text/plain)
2013-11-07 08:02 EST, Lukas Brabec
no flags Details
File: os_info (291 bytes, text/plain)
2013-11-07 08:03 EST, Lukas Brabec
no flags Details
File: program.log (26.36 KB, text/plain)
2013-11-07 08:03 EST, Lukas Brabec
no flags Details
File: storage.log (193.43 KB, text/plain)
2013-11-07 08:03 EST, Lukas Brabec
no flags Details
File: syslog (67.04 KB, text/plain)
2013-11-07 08:03 EST, Lukas Brabec
no flags Details
File: ifcfg.log (650 bytes, text/plain)
2013-11-07 08:03 EST, Lukas Brabec
no flags Details
File: packaging.log (436.16 KB, text/plain)
2013-11-07 08:03 EST, Lukas Brabec
no flags Details

  None (edit)
Description Lukas Brabec 2013-11-07 08:02:27 EST
Description of problem:
Tried to manual partitioning (delete old, autopart, manual change of some settings). 	Accidentally unselected my disk,  bug appeared. after reselecting it again and returning.

Version-Release number of selected component:
anaconda-20.25.6-1

The following was filed automatically by anaconda:
anaconda 20.25.6-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/parted/disk.py", line 269, in removePartition
    if self.__disk.remove_partition(partition.getPedPartition()):
  File "/usr/lib64/python2.7/site-packages/parted/decorators.py", line 41, in new
    ret = fn(*args, **kwds)
  File "/usr/lib/python2.7/site-packages/blivet/partitioning.py", line 595, in removeNewPartitions
    part.disk.format.partedDisk.removePartition(part.partedPartition)
  File "/usr/lib/python2.7/site-packages/blivet/partitioning.py", line 784, in doPartitioning
    removeNewPartitions(disks, partitions)
  File "/usr/lib/python2.7/site-packages/blivet/partitioning.py", line 320, in doAutoPartition
    doPartitioning(storage)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 263, in execute
    doAutoPartition(storage, ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1740, in doKickstartStorage
    ksdata.autopart.execute(storage, ksdata, instClass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 429, in _doExecute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
PartitionException: Partition is not part of the disk it is being removed from

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.6-301.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Beta

Potential duplicate: bug 865653
Comment 1 Lukas Brabec 2013-11-07 08:02:35 EST
Created attachment 821068 [details]
File: anaconda-tb
Comment 2 Lukas Brabec 2013-11-07 08:02:43 EST
Created attachment 821069 [details]
File: anaconda.log
Comment 3 Lukas Brabec 2013-11-07 08:02:47 EST
Created attachment 821070 [details]
File: environ
Comment 4 Lukas Brabec 2013-11-07 08:02:50 EST
Created attachment 821071 [details]
File: lsblk_output
Comment 5 Lukas Brabec 2013-11-07 08:02:59 EST
Created attachment 821072 [details]
File: nmcli_dev_list
Comment 6 Lukas Brabec 2013-11-07 08:03:05 EST
Created attachment 821073 [details]
File: os_info
Comment 7 Lukas Brabec 2013-11-07 08:03:09 EST
Created attachment 821074 [details]
File: program.log
Comment 8 Lukas Brabec 2013-11-07 08:03:14 EST
Created attachment 821075 [details]
File: storage.log
Comment 9 Lukas Brabec 2013-11-07 08:03:18 EST
Created attachment 821076 [details]
File: syslog
Comment 10 Lukas Brabec 2013-11-07 08:03:23 EST
Created attachment 821077 [details]
File: ifcfg.log
Comment 11 Lukas Brabec 2013-11-07 08:03:29 EST
Created attachment 821078 [details]
File: packaging.log
Comment 12 Lukas Brabec 2013-11-07 08:17:33 EST
1) storage -> done -> custom partitioning
2) delete (all) old and create new automatically
3) done -> accept
4) (accidentally, as used from previous Fedora) unselect disk -> done
5) select disk again -> done -> continue

It seems that the problem is 'create new automaticaly' in custom partitioning with reselecting of disk (this probably appeared in https://bugzilla.redhat.com/show_bug.cgi?id=978298 which is still broken).
When replacing steps 1 and 2 with space reclaiming bug doesn't appear.
Comment 13 Lukas Brabec 2013-11-07 08:33:41 EST
Proposing as beta blocker (alongside with bug 978298) - violation of criterion: Custom partitioning (Reject or disallow invalid disk and volume configurations without crashing).
Comment 14 Kamil Páral 2013-11-07 12:55:12 EST
Reproduced bug 1027846 exactly as in comment 12.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.6-301.fc20.x86_64
package:        anaconda-20.25.6-1
product:        Fedora
reason:         PartitionException: Partition is not part of the disk it is being removed from
release:        Cannot get release name.
version:        20-Beta
Comment 15 Mike Ruckman 2013-11-07 13:00:24 EST
Discussed in the 2013-11-07 Go/No-Go meeting [1]. Voted as a RejectedBlocker as going through the partitioning spoke multiple times was deemed not worthy of blocking beta and thus, this bug is rejected as a blocker for Fedora 20 beta. Please re-propose as a blocker for F20 final and mark for inclusion in CommonBugs.

[1] http://meetbot.fedoraproject.org/meetbot/meetbot/fedora-meeting-2/2013-11-07/
Comment 16 Fedora Update System 2013-11-15 21:18:44 EST
anaconda-20.25.8-1.fc20, pykickstart-1.99.46-1.fc20, python-blivet-0.23.5-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/pykickstart-1.99.46-1.fc20,python-blivet-0.23.5-1.fc20,anaconda-20.25.8-1.fc20
Comment 17 Fedora Update System 2013-11-17 02:03:49 EST
Package anaconda-20.25.8-1.fc20, pykickstart-1.99.46-1.fc20, python-blivet-0.23.5-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-20.25.8-1.fc20 pykickstart-1.99.46-1.fc20 python-blivet-0.23.5-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21553/pykickstart-1.99.46-1.fc20,python-blivet-0.23.5-1.fc20,anaconda-20.25.8-1.fc20
then log in and leave karma (feedback).
Comment 18 lnie 2013-11-20 22:27:00 EST
fixed with anaconda-20.25.8-1.fc20
Comment 19 Lukas Brabec 2013-11-21 05:50:16 EST
anaconda-20.25.8-1.fc20 fixed the problem
Comment 20 Kamil Páral 2013-11-21 07:38:05 EST
Guys, set to VERIFIED then, thanks.
Comment 21 Fedora Update System 2013-11-23 22:59:34 EST
pykickstart-1.99.46-1.fc20, python-blivet-0.23.5-1.fc20, anaconda-20.25.9-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.